You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@jackrabbit.apache.org by "Tobias Bocanegra (JIRA)" <ji...@apache.org> on 2006/07/17 19:24:14 UTC
[jira] Updated: (JCR-476) Remove recently added
getJCRPath()/getQPath() from NamespaceResolver
[ http://issues.apache.org/jira/browse/JCR-476?page=all ]
Tobias Bocanegra updated JCR-476:
---------------------------------
Attachment: jackrabbit.422765.patch
created patch.
> Remove recently added getJCRPath()/getQPath() from NamespaceResolver
> --------------------------------------------------------------------
>
> Key: JCR-476
> URL: http://issues.apache.org/jira/browse/JCR-476
> Project: Jackrabbit
> Issue Type: Improvement
> Affects Versions: 1.1
> Reporter: Tobias Bocanegra
> Assigned To: Tobias Bocanegra
> Priority: Minor
> Attachments: jackrabbit.422765.patch
>
>
> issue JCR-473 added 2 new methods to NamespaceResolver:
> public Path getQPath(String jcrPath) throws MalformedPathException;
> public String getJCRPath(Path qPath) throws NoPrefixDeclaredException;
> which do not belong here, since the NamespaceResolver has nothing to do with paths. suggest to remove them.
> further is the naming of the QName related methods a bit vague. suggest to rename them to:
> QName parseName(String jcrName)
> String formatName(QName qName)
> (although they do not belong here either, but helps to leverage evt. caching namespace resolvers).
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira