You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@felix.apache.org by "David Leangen (JIRA)" <ji...@apache.org> on 2016/09/03 07:45:20 UTC

[jira] [Created] (FELIX-5338) Clarification of Converter.getAdapter()

David Leangen created FELIX-5338:
------------------------------------

             Summary: Clarification of Converter.getAdapter()
                 Key: FELIX-5338
                 URL: https://issues.apache.org/jira/browse/FELIX-5338
             Project: Felix
          Issue Type: Improvement
          Components: Converter
            Reporter: David Leangen


Hi!

The intent of Converter.getAdapter() is not quite clear to me.

{code}
	/**
	 * Obtain an adapter to this converter. The adapter behaves just like the
	 * converter except for the exception rules registered with is. For more
	 * details see the {@link Adapter} interface.
	 * 
	 * @return An adapter to this converter.
	 */
	Adapter getAdapter();
{code}

Is this supposed to return an *existing* Adapter? Or rather, should it return a *new* Adapter.

My guess is the latter, and the implementation code aligns with my expectation. However, it is not clear from the documentation or the API.

Suggestion: the method should be renamed to "newAdapter()".



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)