You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@wicket.apache.org by "Philippe Marschall (JIRA)" <ji...@apache.org> on 2009/04/12 15:04:15 UTC

[jira] Created: (WICKET-2222) MixedParamUrlCodingStrategy constructor should be variadic

MixedParamUrlCodingStrategy constructor should be variadic
----------------------------------------------------------

                 Key: WICKET-2222
                 URL: https://issues.apache.org/jira/browse/WICKET-2222
             Project: Wicket
          Issue Type: Wish
          Components: wicket
    Affects Versions: 1.4-RC2
            Reporter: Philippe Marschall
            Priority: Minor


If the following constructor:
{code}
public MixedParamUrlCodingStrategy(String mountPath, Class bookmarkablePageClass,
		String[] parameterNames)
{code}
would instead be defined as:
{code}
public MixedParamUrlCodingStrategy(String mountPath, Class bookmarkablePageClass,
		String... parameterNames)
{code}
The following code:
{code}
new MixedParamUrlCodingStrategy("products",ProductDetailPage.class, new String[]{"id"});
{code}
could be simplified into:
{code}
new MixedParamUrlCodingStrategy("products",ProductDetailPage.class, "id");
{code}

This change would be API and ABI compilant.


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Reopened: (WICKET-2222) MixedParamUrlCodingStrategy constructor should be variadic

Posted by "Philippe Marschall (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/WICKET-2222?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Philippe Marschall reopened WICKET-2222:
----------------------------------------


I'm sorry, I just had a look at -rc4 and noted that it will not work as expected. The problem is the second constructor who's last parameter are a String and a String array. javac will always report an ambiguous reference and never compile client code. I think the patch should be reverted.

> MixedParamUrlCodingStrategy constructor should be variadic
> ----------------------------------------------------------
>
>                 Key: WICKET-2222
>                 URL: https://issues.apache.org/jira/browse/WICKET-2222
>             Project: Wicket
>          Issue Type: Wish
>          Components: wicket
>    Affects Versions: 1.4-RC2
>            Reporter: Philippe Marschall
>            Assignee: Juergen Donnerstag
>            Priority: Minor
>             Fix For: 1.4-RC3
>
>
> If the following constructor:
> {code}
> public MixedParamUrlCodingStrategy(String mountPath, Class bookmarkablePageClass,
> 		String[] parameterNames)
> {code}
> would instead be defined as:
> {code}
> public MixedParamUrlCodingStrategy(String mountPath, Class bookmarkablePageClass,
> 		String... parameterNames)
> {code}
> The following code:
> {code}
> new MixedParamUrlCodingStrategy("products",ProductDetailPage.class, new String[]{"id"});
> {code}
> could be simplified into:
> {code}
> new MixedParamUrlCodingStrategy("products",ProductDetailPage.class, "id");
> {code}
> This change would be API and ABI compilant.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Resolved: (WICKET-2222) MixedParamUrlCodingStrategy constructor should be variadic

Posted by "Juergen Donnerstag (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/WICKET-2222?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Juergen Donnerstag resolved WICKET-2222.
----------------------------------------

       Resolution: Invalid
    Fix Version/s:     (was: 1.4-RC3)
                   1.4-RC4

change reverted

> MixedParamUrlCodingStrategy constructor should be variadic
> ----------------------------------------------------------
>
>                 Key: WICKET-2222
>                 URL: https://issues.apache.org/jira/browse/WICKET-2222
>             Project: Wicket
>          Issue Type: Wish
>          Components: wicket
>    Affects Versions: 1.4-RC2
>            Reporter: Philippe Marschall
>            Assignee: Juergen Donnerstag
>            Priority: Minor
>             Fix For: 1.4-RC4
>
>
> If the following constructor:
> {code}
> public MixedParamUrlCodingStrategy(String mountPath, Class bookmarkablePageClass,
> 		String[] parameterNames)
> {code}
> would instead be defined as:
> {code}
> public MixedParamUrlCodingStrategy(String mountPath, Class bookmarkablePageClass,
> 		String... parameterNames)
> {code}
> The following code:
> {code}
> new MixedParamUrlCodingStrategy("products",ProductDetailPage.class, new String[]{"id"});
> {code}
> could be simplified into:
> {code}
> new MixedParamUrlCodingStrategy("products",ProductDetailPage.class, "id");
> {code}
> This change would be API and ABI compilant.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Resolved: (WICKET-2222) MixedParamUrlCodingStrategy constructor should be variadic

Posted by "Juergen Donnerstag (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/WICKET-2222?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Juergen Donnerstag resolved WICKET-2222.
----------------------------------------

       Resolution: Fixed
    Fix Version/s: 1.4-RC3
         Assignee: Juergen Donnerstag

applied. Thanks

> MixedParamUrlCodingStrategy constructor should be variadic
> ----------------------------------------------------------
>
>                 Key: WICKET-2222
>                 URL: https://issues.apache.org/jira/browse/WICKET-2222
>             Project: Wicket
>          Issue Type: Wish
>          Components: wicket
>    Affects Versions: 1.4-RC2
>            Reporter: Philippe Marschall
>            Assignee: Juergen Donnerstag
>            Priority: Minor
>             Fix For: 1.4-RC3
>
>
> If the following constructor:
> {code}
> public MixedParamUrlCodingStrategy(String mountPath, Class bookmarkablePageClass,
> 		String[] parameterNames)
> {code}
> would instead be defined as:
> {code}
> public MixedParamUrlCodingStrategy(String mountPath, Class bookmarkablePageClass,
> 		String... parameterNames)
> {code}
> The following code:
> {code}
> new MixedParamUrlCodingStrategy("products",ProductDetailPage.class, new String[]{"id"});
> {code}
> could be simplified into:
> {code}
> new MixedParamUrlCodingStrategy("products",ProductDetailPage.class, "id");
> {code}
> This change would be API and ABI compilant.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.