You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@camel.apache.org by "Claus Ibsen (Created) (JIRA)" <ji...@apache.org> on 2011/09/28 08:03:46 UTC

[jira] [Created] (CAMEL-4496) IdempotentConsumer EIP - Add option to control if it should undo on failure or not

IdempotentConsumer EIP - Add option to control if it should undo on failure or not
----------------------------------------------------------------------------------

                 Key: CAMEL-4496
                 URL: https://issues.apache.org/jira/browse/CAMEL-4496
             Project: Camel
          Issue Type: Improvement
          Components: camel-core
            Reporter: Claus Ibsen
            Priority: Minor
             Fix For: 2.9.0


We need a new option on Idempotent Consumer EIP.

Boolean undoOnFailure

Which should act default as "true".

This allows end users to control that in case the Exchange failed, then the idempotent consumer should either
keep the id in the repository, or undo adding the id (the current behavior).

Some users have reasons for the idempotent consumer to not accept a redelivery of a previously failed exchange.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Assigned] (CAMEL-4496) IdempotentConsumer EIP - Add option to control if it should undo on failure or not

Posted by "Ioannis Canellos (Assigned) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CAMEL-4496?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Ioannis Canellos reassigned CAMEL-4496:
---------------------------------------

    Assignee: Ioannis Canellos
    
> IdempotentConsumer EIP - Add option to control if it should undo on failure or not
> ----------------------------------------------------------------------------------
>
>                 Key: CAMEL-4496
>                 URL: https://issues.apache.org/jira/browse/CAMEL-4496
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-core
>            Reporter: Claus Ibsen
>            Assignee: Ioannis Canellos
>            Priority: Minor
>             Fix For: 2.9.0
>
>
> We need a new option on Idempotent Consumer EIP.
> Boolean undoOnFailure
> Which should act default as "true".
> This allows end users to control that in case the Exchange failed, then the idempotent consumer should either
> keep the id in the repository, or undo adding the id (the current behavior).
> Some users have reasons for the idempotent consumer to not accept a redelivery of a previously failed exchange.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (CAMEL-4496) IdempotentConsumer EIP - Add option to control if it should undo on failure or not

Posted by "Ioannis Canellos (Updated) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CAMEL-4496?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Ioannis Canellos updated CAMEL-4496:
------------------------------------

    Attachment: CAMEL-4496-patch.txt

I am attaching a patch, which adds the property removeOnFailure on the idempotent consumer. Also adds a unit test in camel-core and camel-spring to test the use of the property from java dsl and spring.
                
> IdempotentConsumer EIP - Add option to control if it should undo on failure or not
> ----------------------------------------------------------------------------------
>
>                 Key: CAMEL-4496
>                 URL: https://issues.apache.org/jira/browse/CAMEL-4496
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-core
>            Reporter: Claus Ibsen
>            Assignee: Ioannis Canellos
>            Priority: Minor
>             Fix For: 2.9.0
>
>         Attachments: CAMEL-4496-patch.txt
>
>
> We need a new option on Idempotent Consumer EIP.
> Boolean undoOnFailure
> Which should act default as "true".
> This allows end users to control that in case the Exchange failed, then the idempotent consumer should either
> keep the id in the repository, or undo adding the id (the current behavior).
> Some users have reasons for the idempotent consumer to not accept a redelivery of a previously failed exchange.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (CAMEL-4496) IdempotentConsumer EIP - Add option to control if it should undo on failure or not

Posted by "Claus Ibsen (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/CAMEL-4496?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13116348#comment-13116348 ] 

Claus Ibsen commented on CAMEL-4496:
------------------------------------

Thanks for the patch.

I had to fix a minor typo in one of the javadocs.
I adjusted the unit test to test for the non-default setting which would be removeOnFailure=false. You had the test for =true.
Likewise I adjusted the unit test in camel-spring to extend the unit test from camel-core. 

Take a look at the commit log, for how this can be done.

Ioannis do you mind updating the wiki page of the idempotent consumer EIP with this new option.
                
> IdempotentConsumer EIP - Add option to control if it should undo on failure or not
> ----------------------------------------------------------------------------------
>
>                 Key: CAMEL-4496
>                 URL: https://issues.apache.org/jira/browse/CAMEL-4496
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-core
>            Reporter: Claus Ibsen
>            Assignee: Ioannis Canellos
>            Priority: Minor
>             Fix For: 2.9.0
>
>         Attachments: CAMEL-4496-patch.txt
>
>
> We need a new option on Idempotent Consumer EIP.
> Boolean undoOnFailure
> Which should act default as "true".
> This allows end users to control that in case the Exchange failed, then the idempotent consumer should either
> keep the id in the repository, or undo adding the id (the current behavior).
> Some users have reasons for the idempotent consumer to not accept a redelivery of a previously failed exchange.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Resolved] (CAMEL-4496) IdempotentConsumer EIP - Add option to control if it should undo on failure or not

Posted by "Ioannis Canellos (Resolved) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CAMEL-4496?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Ioannis Canellos resolved CAMEL-4496.
-------------------------------------

    Resolution: Fixed

Patch committed and documentation has been updated.
                
> IdempotentConsumer EIP - Add option to control if it should undo on failure or not
> ----------------------------------------------------------------------------------
>
>                 Key: CAMEL-4496
>                 URL: https://issues.apache.org/jira/browse/CAMEL-4496
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-core
>            Reporter: Claus Ibsen
>            Assignee: Ioannis Canellos
>            Priority: Minor
>             Fix For: 2.9.0
>
>         Attachments: CAMEL-4496-patch.txt
>
>
> We need a new option on Idempotent Consumer EIP.
> Boolean undoOnFailure
> Which should act default as "true".
> This allows end users to control that in case the Exchange failed, then the idempotent consumer should either
> keep the id in the repository, or undo adding the id (the current behavior).
> Some users have reasons for the idempotent consumer to not accept a redelivery of a previously failed exchange.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (CAMEL-4496) IdempotentConsumer EIP - Add option to control if it should undo on failure or not

Posted by "Charles Moulliard (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/CAMEL-4496?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13116262#comment-13116262 ] 

Charles Moulliard commented on CAMEL-4496:
------------------------------------------

A better name for this option could be "removeOnFailure" as the idea is to remove (or not) the exchange from the cache of the idempotentConsumer
                
> IdempotentConsumer EIP - Add option to control if it should undo on failure or not
> ----------------------------------------------------------------------------------
>
>                 Key: CAMEL-4496
>                 URL: https://issues.apache.org/jira/browse/CAMEL-4496
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-core
>            Reporter: Claus Ibsen
>            Priority: Minor
>             Fix For: 2.9.0
>
>
> We need a new option on Idempotent Consumer EIP.
> Boolean undoOnFailure
> Which should act default as "true".
> This allows end users to control that in case the Exchange failed, then the idempotent consumer should either
> keep the id in the repository, or undo adding the id (the current behavior).
> Some users have reasons for the idempotent consumer to not accept a redelivery of a previously failed exchange.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira