You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@sling.apache.org by jo...@apache.org on 2025/03/05 08:48:30 UTC

(sling-org-apache-sling-resourceresolver) branch SLING-12244-cache-parentResourceType updated (4d2e104c -> 04eb185c)

This is an automated email from the ASF dual-hosted git repository.

joerghoh pushed a change to branch SLING-12244-cache-parentResourceType
in repository https://gitbox.apache.org/repos/asf/sling-org-apache-sling-resourceresolver.git


    from 4d2e104c store the resourceSuperType mapping into a dedicated map, not in the propertyMap
     add d039940c SLING-12381 : Always clear provider context on deactivate
     add 23d16d1d SLING-12382 : Potential concurrency issues with resource provider registration/unregistration
     add 9310ca5d SLING-12382 : Potential concurrency issues with resource provider registration/unregistration
     add 3b890d27 SLING-12382 : Potential concurrency issues with resource provider registration/unregistration
     add 7bf75d45 SLING-12382 : Potential concurrency issues with resource provider registration/unregistration
     add a3eb20f5 SLING-12382 : Potential concurrency issues with resource provider registration/unregistration
     add a6e642e0 Fix javadoc errors
     add d33a37c0 SLING-12382 : Potential concurrency issues with resource provider registration/unregistration
     add 1e885045 SLING-12383: ResourceResolver: potential NPE while processing aliases (#118)
     add 42d3c670 log something in case the vanity path initializer fails (#116)
     add 07e6ca09 SLING-12371 always update the metric of unclosed RRs (#117)
     add 2a7960a1 SLING-12387: ResourceResolver: improve test coverage for PagedQueryIterator (#120)
     add d47a6b0e SLING-12389 : All resource resolver operations should check for a closed
     add a0270a0c SLING-12384: ResourceResolver: paged query for sling:alias will miss entries when 'first(sling:alias)' is empty (#119)
     add ba3e4cbe [maven-release-plugin] prepare release org.apache.sling.resourceresolver-1.12.0
     add 428f8a7d [maven-release-plugin] prepare for next development iteration
     add 844b2381 SLING-12401: MapEntries.isAliasValid() misnamed - rename to isAliasInvalid() (#121)
     add d6f19d39 SLING-12412: ResourceResolver: add test coverage for empty aliases, blank aliases, and invalid aliases (#122)
     add 94cc1bb2 SLING-12399: make empty alias invalid (#123)
     add 53daef23 SLING-12400: ResourceResolver: add test coverage for aliases on jcr:content nodes and NPEs on getParent, refactor associated code (#124)
     add ab069e60 [maven-release-plugin] prepare release org.apache.sling.resourceresolver-1.12.2
     add eda9da1f [maven-release-plugin] prepare for next development iteration
     add 9e3f3161 SLING-12459 - Redirect sonarcloud notifications to commits@apache.sling.org
     add 6459b962 SLING-12402: ResourceResolver: add additional log entry when there are many conflicting or invalid aliases (also add metrics) (#125)
     add c359a8b3 SLING-12611: Resource Resolver: refactor MapEntries - extract PagedQueryIterator (#127)
     add 1ff93f0c SLING-12618: Resource Resolver: MapEntries: remove dead code in getMapEntry (#128)
     add 99f07e96 SLING-12619: Resource Resolver: MapEntries.loadVanityPath: use parameter instead of relying on object comparison (#129)
     add 518def32 SLING-12620: Resource Resolver: needs to handle getParent()==null for vanity path resources gracefully (#130)
     add b7ce082e Resource Resolver: refactor MapEntries - improve MapIterator test coverage
     add 3cf18413 Revert "Resource Resolver: refactor MapEntries - improve MapIterator test coverage"
     add 7c432e97 Resource Resolver: refactor MapEntries - improve MapIterator test coverage (#132)
     add aad3493f SLING-12630: Resource Resolver: refactor MapEntries - extract MapIterator into separate class (#133)
     add 019ed5cb SLING-12621: Resource Resolver: refactor MapEntries - refactor MapIterator (#131)
     add 5557ab79 SLING-12632: move all (only) vanity path related code in a single place (#134)
     add b4be9cee SLING-12634: Resource Resolver: isMaxCachedVanityPathEntriesStartup check does not handle unlimited cache size (#135)
     add 3cd39de3 [maven-release-plugin] prepare release org.apache.sling.resourceresolver-1.12.4
     add 6077918a [maven-release-plugin] prepare for next development iteration
     add ba7588bc SLING-12636: Resource Resolver: add test coverage for background init (#136)
     add 7ca429a8 Revert "SLING-12636: Resource Resolver: add test coverage for background init (#136)"
     add 4df109b0 SLING-12636: Resource Resolver: add test coverage for background init
     add ea037cdf SLING-12636: Resource Resolver: add test coverage for background init - fix MapEntries internal state when loadVanityPaths is called a second time
     add 248e49b3 SLING-12636: Resource Resolver - fix test
     add 1fe660c2 Revert "SLING-12636: Resource Resolver - fix test"
     add c983862e SLING-12636: Resource Resolver - fix test to properly initialize and adjust test expections (and explain them)
     add 70905da4 SLING-12636 improve logging of fixture setup
     add 0e2bed98 SLING-12636: fix test page post PR
     add 0dc3c2ba SLING-12645: VanityPathMapEntries - remove (attempted) tests for query paging (#137)
     add 6fc48d0e SLING-12646: MapEntries: give doInit() a meaningful name (#138)
     add fb414865 SLING-12649: VanityPathMapEntriesTest - factor out repeated uses of reflection (#139)
     add 029a385a SLING-12653: add test coverage for query exception disabling optimized alias handling (#141)
     add ff16b436 SLING-12651: avoid re-assignment of resolveMapsMap (#140)
     add 8aa44a2b SLING-12658: refactor vanity path handling - encapsulate code for better isolation and unit testing (#142)
     add f25ed578  OAK-12658: move methods to minimize diffs after extracting vp handling (#143)
     add 28cdba16 SLING-12648: MapEntries: factor out vanity path handling into inner class (#145)
     add 84067381 SLING-12664: MapEntries: drainQueue is part of event handling (move it there) (#146)
     add b408309f SLING-12665: extract VanityPathHandler into separate class (#148)
     add 7eaef330 SLING-12667: cleanup/improve VanityPathMapEntriesTest  (#150)
     add f88ccd95 SLING-12671: add test coverage for vanity paths on resources with name extensions (#151)
     add 08ebd440 SLING-12666: VanityPathHandler, address warnings, refactor (#152)
     add 466a128f SLING-12679: fix incorrect metrics init (#153)
     add 92b4b716 SLING-12684: update to latest Sling parent pom
     add 76350573 Revert "SLING-12684: update to latest Sling parent pom"
     add 9ec0dc4c  SLING-12683: extract alias tests from MapEntriesTest  (#154)
     add 04eb185c Merge branch 'master' into SLING-12244-cache-parentResourceType

No new revisions were added by this update.

Summary of changes:
 .asf.yaml                                          |    1 +
 pom.xml                                            |    6 +-
 .../impl/CommonResourceResolverFactoryImpl.java    |   18 +-
 .../impl/FactoryPreconditions.java                 |   11 +-
 .../impl/FactoryRegistrationHandler.java           |    6 +-
 .../impl/ResourceResolverFactoryActivator.java     |    7 +-
 .../impl/ResourceResolverImpl.java                 |   23 +-
 .../impl/ResourceResolverMetrics.java              |   77 +-
 .../impl/helper/AbstractIterator.java              |    5 +-
 .../resourceresolver/impl/mapping/MapEntries.java  | 1103 ++--------
 .../impl/mapping/MapEntryIterator.java             |  171 ++
 .../impl/mapping/PagedQueryIterator.java           |  182 ++
 ...polationProvider.java => QueryBuildHelper.java} |   35 +-
 .../impl/mapping/VanityPathHandler.java            |  727 +++++++
 .../impl/providers/ResourceProviderHandler.java    |   56 +-
 .../impl/providers/ResourceProviderTracker.java    |  329 ++-
 .../impl/FactoryPreconditionsTest.java             |   32 +-
 .../impl/FactoryRegistrationHandlerTest.java       |   25 +-
 .../impl/MockedResourceResolverImplTest.java       |    2 +-
 .../impl/ResourceResolverImplTest.java             |    1 -
 .../impl/ResourceResolverMetricsTest.java          |   86 +-
 .../impl/helper/ResourceResolverControlTest.java   |   10 +-
 .../impl/mapping/AliasMapEntriesTest.java          | 1151 ++++++++++
 .../impl/mapping/EtcMappingMapEntriesTest.java     |   12 +-
 .../impl/mapping/MapEntriesTest.java               | 2267 +-------------------
 .../impl/mapping/MapEntryIteratorTest.java         |  158 ++
 .../impl/mapping/PagedQueryIteratorTest.java       |  198 ++
 .../impl/mapping/PathGeneratorTest.java            |   14 +
 .../mapping/StringInterpolationMapEntriesTest.java |    4 +-
 .../impl/mapping/VanityPathMapEntriesTest.java     | 1365 ++++++++++++
 .../providers/ResourceProviderStorageTest.java     |    6 +-
 .../providers/ResourceProviderTrackerTest.java     |   20 +-
 32 files changed, 4616 insertions(+), 3492 deletions(-)
 create mode 100644 src/main/java/org/apache/sling/resourceresolver/impl/mapping/MapEntryIterator.java
 create mode 100644 src/main/java/org/apache/sling/resourceresolver/impl/mapping/PagedQueryIterator.java
 copy src/main/java/org/apache/sling/resourceresolver/impl/mapping/{StringInterpolationProvider.java => QueryBuildHelper.java} (55%)
 create mode 100644 src/main/java/org/apache/sling/resourceresolver/impl/mapping/VanityPathHandler.java
 create mode 100644 src/test/java/org/apache/sling/resourceresolver/impl/mapping/AliasMapEntriesTest.java
 create mode 100644 src/test/java/org/apache/sling/resourceresolver/impl/mapping/MapEntryIteratorTest.java
 create mode 100644 src/test/java/org/apache/sling/resourceresolver/impl/mapping/PagedQueryIteratorTest.java
 create mode 100644 src/test/java/org/apache/sling/resourceresolver/impl/mapping/VanityPathMapEntriesTest.java