You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@cassandra.apache.org by "Robert Coli (JIRA)" <ji...@apache.org> on 2013/07/30 01:27:49 UTC
[jira] [Commented] (CASSANDRA-4694) populate_io_cache_on_flush
option should be configurable for each column family independently
[ https://issues.apache.org/jira/browse/CASSANDRA-4694?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13723129#comment-13723129 ]
Robert Coli commented on CASSANDRA-4694:
----------------------------------------
populate_io_cache_on_flush seems misnamed for something which affects behavior both at flush time (_on_flush) and at compaction time (_on_compaction?).
With the current name, there is a risk of users becoming confused and thinking that the process of writing out a SSTable is a "flush", when in Cassandra 99.9% of the time a "flush" is in fact the process of turning a memtable into a SSTable.
http://pastebin.com/GJMVZP9v
Shows that the overwhelming majority of uses of "flush" in user visible code paths refer only to the concept of "flush"ing a memtable.
I understand that the function in question is called "flushInternal," but submit that we are inviting confusion by conflating the specific "flush"ing of a memtable with generic "flush"ing data to disk. :)
"populate_io_cache_on_create" maybe? with "create" referring to the new file being "create"d on disk? I am willing to submit a patch if needed..
> populate_io_cache_on_flush option should be configurable for each column family independently
> ---------------------------------------------------------------------------------------------
>
> Key: CASSANDRA-4694
> URL: https://issues.apache.org/jira/browse/CASSANDRA-4694
> Project: Cassandra
> Issue Type: Improvement
> Components: Core
> Reporter: Alexey Zotov
> Assignee: Alexey Zotov
> Priority: Minor
> Labels: cli, core, documentation
> Fix For: 1.2.2
>
> Attachments: cassandra-1.1.2-4694-populate_io_cache_v3.txt, cassandra-1.1-4694-populate_io_cache.txt, cassandra-1.2-4694-populate_io_cache.txt, cassandra-1.2-4694-populate_io_cache_v2.txt, cassandra-1.2-populate_io_cache_v4.txt
>
>
> I suggest to configure populate_io_cache_on_flush option for each column family. It should be configurable from cassandra-cli and should be stored in System keyspace.
> That could be useful if you have a few column families inside single keyspace and you need to fit in memory only one of them.
> Patch has been attached. I've been testing it on pseudo-cluster using ccm. So I don't have fully confidence about lack of bugs. Please carefully review that code.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira