You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@subversion.apache.org by Mark Benedetto King <mb...@lowlatency.com> on 2004/08/30 14:55:44 UTC

Re: svn commit: r10772 - trunk/subversion/libsvn_client

On Mon, Aug 30, 2004 at 05:44:47AM -0500, jpieper@tigris.org wrote:
>  
> -  if ((entry->kind == svn_node_file)
> -      && (! propval)
> -      && (is_special))
> +  if (((! propval) && (is_special)) ||
> +          ((propval) && (! is_special)))
>      {

An alternative form:

     if ((! propval) != (! is_special))
       {

Ignoring readability, there is a performance reason for this change:
most C optimizers aren't smart enough to prove that the original's
short-circuiting branches are unneccesary.

--ben


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org