You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Charles Lamb (JIRA)" <ji...@apache.org> on 2014/12/01 23:10:12 UTC
[jira] [Commented] (HDFS-7450) Consolidate GetFileInfo, GetListings
and GetContentSummary into a single class
[ https://issues.apache.org/jira/browse/HDFS-7450?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14230547#comment-14230547 ]
Charles Lamb commented on HDFS-7450:
------------------------------------
[~wheat9],
Thanks for working continuing to work on this.
FSDirectory.java:
You might as well remove the import DirectorySnapshottableFeature since it's unused.
FSEditLogLoader.java:
Line 375 busts the 80 char limit.
FSNamesystem.java:
line 2476 busts the 80 char limit.
#getFileInfo used to have a call to checkOperation(READ) before (and after) the readLock(). Now it only has one inside the readLock() context. Ditto #isFileClosed() and #getListing(). I assume they used to be outside the readLock() call for failfast purposes.
> Consolidate GetFileInfo, GetListings and GetContentSummary into a single class
> ------------------------------------------------------------------------------
>
> Key: HDFS-7450
> URL: https://issues.apache.org/jira/browse/HDFS-7450
> Project: Hadoop HDFS
> Issue Type: Sub-task
> Reporter: Haohui Mai
> Assignee: Haohui Mai
> Attachments: HDFS-7450.000.patch, HDFS-7450.001.patch, HDFS-7450.002.patch, HDFS-7450.003.patch
>
>
> This jira proposes to consolidate the implementation of {{GetFileInfo}}, {{GetListings}} and {{GetContentSummary}} into a single class.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)