You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@samza.apache.org by "Chris Riccomini (JIRA)" <ji...@apache.org> on 2013/08/22 23:41:51 UTC

[jira] [Updated] (SAMZA-44) Change "state topic" phrasing in KafkaCheckpointManager

     [ https://issues.apache.org/jira/browse/SAMZA-44?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Chris Riccomini updated SAMZA-44:
---------------------------------

    Description: 
Currently, we refer to stateTopic and "state topic" in KafkaCheckpointManager. For example:

{code}
if (offset <= 0) {
  info("Got offset 0 (no messages in state topic) for topic %s and partition %s, so returning null. If you expected the state topic to have messages, you're probably going to lose data." format (stateTopic, partition))
  return null
}
{code}

This is a misleading phrase, and variable name. We should rename all mentions of state topic to checkpoint topic, so it doesn't get confused with ACTUAL state topics (LoggedStores).

  was:
Currently, we refer to stateTopic and "state topic" in KafkaCheckpointManager. For example:

{code}
if (offset <= 0) {
          info("Got offset 0 (no messages in state topic) for topic %s and partition %s, so returning null. If you expected the state topic to have messages, you're probably going to lose data." format (stateTopic, partition))
          return null
        }
{code}

This is a misleading phrase, and variable name. We should rename all mentions of state topic to checkpoint topic, so it doesn't get confused with ACTUAL state topics (LoggedStores).

    
> Change "state topic" phrasing in KafkaCheckpointManager
> -------------------------------------------------------
>
>                 Key: SAMZA-44
>                 URL: https://issues.apache.org/jira/browse/SAMZA-44
>             Project: Samza
>          Issue Type: Bug
>          Components: kafka
>    Affects Versions: 0.6.0
>            Reporter: Chris Riccomini
>             Fix For: 0.7.0
>
>
> Currently, we refer to stateTopic and "state topic" in KafkaCheckpointManager. For example:
> {code}
> if (offset <= 0) {
>   info("Got offset 0 (no messages in state topic) for topic %s and partition %s, so returning null. If you expected the state topic to have messages, you're probably going to lose data." format (stateTopic, partition))
>   return null
> }
> {code}
> This is a misleading phrase, and variable name. We should rename all mentions of state topic to checkpoint topic, so it doesn't get confused with ACTUAL state topics (LoggedStores).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira