You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@zookeeper.apache.org by "Thomas Koch (JIRA)" <ji...@apache.org> on 2010/10/21 13:11:15 UTC

[jira] Updated: (ZOOKEEPER-908) Remove code duplication and inconsistent naming in ClientCnxn.Packet creation

     [ https://issues.apache.org/jira/browse/ZOOKEEPER-908?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Thomas Koch updated ZOOKEEPER-908:
----------------------------------

    Attachment: ZOOKEEPER-908.patch

ant test-core did work without failures.

> Remove code duplication and inconsistent naming in ClientCnxn.Packet creation
> -----------------------------------------------------------------------------
>
>                 Key: ZOOKEEPER-908
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-908
>             Project: Zookeeper
>          Issue Type: Sub-task
>            Reporter: Thomas Koch
>         Attachments: ZOOKEEPER-908.patch
>
>
> rename record -> request (since their is a counterpart record named "response")
> rename header -> requestHeader (to distinguish from responseHeader)
> remove ByteBuffer creation code from primeConnection() method and use the duplicate code in the Packet constructor. Therefor the Bytebuffer bb parameter could also be removed from the constructor's parameters.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.