You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-issues@hadoop.apache.org by "Tom White (JIRA)" <ji...@apache.org> on 2010/09/07 14:34:33 UTC
[jira] Updated: (HADOOP-6940) RawLocalFileSystem's markSupported
method misnamed markSupport
[ https://issues.apache.org/jira/browse/HADOOP-6940?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Tom White updated HADOOP-6940:
------------------------------
Attachment: HADOOP-6940.patch
Patch which uses @Override to avoid this bug. It would be a good exercise to go through the code and use this annotation more widely.
> RawLocalFileSystem's markSupported method misnamed markSupport
> --------------------------------------------------------------
>
> Key: HADOOP-6940
> URL: https://issues.apache.org/jira/browse/HADOOP-6940
> Project: Hadoop Common
> Issue Type: Bug
> Components: fs
> Reporter: Tom White
> Assignee: Tom White
> Priority: Minor
> Attachments: HADOOP-6940.patch
>
>
> It should be named markSupported to override the method defined in InputStream. Since it doesn't change the default no harm is done.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.