You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@hudi.apache.org by "Y Ethan Guo (Jira)" <ji...@apache.org> on 2025/03/04 18:32:00 UTC
[jira] [Updated] (HUDI-8373) Improve variable naming around time in incremental query logic
[ https://issues.apache.org/jira/browse/HUDI-8373?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Y Ethan Guo updated HUDI-8373:
------------------------------
Parent: HUDI-9107 (was: HUDI-8718)
> Improve variable naming around time in incremental query logic
> --------------------------------------------------------------
>
> Key: HUDI-8373
> URL: https://issues.apache.org/jira/browse/HUDI-8373
> Project: Apache Hudi
> Issue Type: Sub-task
> Components: code-quality
> Reporter: Y Ethan Guo
> Priority: Critical
> Fix For: 1.0.2
>
> Original Estimate: 6h
> Remaining Estimate: 6h
>
> It can be confusing to use "Start" or "Time" without much context as we have the checkpoint to resume from and stop at for the incremental queries, and instant and completion time in the timeline. So it would be good to do the following renaming and make the names consistent across the code base:
> * "beginCompletionTime": checkpoint to resume from
> * "endCompletionTime": checkpoint to stop at
> * "instantTime"/"commitTime": for instant time or start time of an instant on the timeline
> * "completionTime": completion time of an instant
> Do not use "startTime", "endTime", etc that can cause confusion.
>
--
This message was sent by Atlassian Jira
(v8.20.10#820010)