You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by "Mikhail Khludnev (JIRA)" <ji...@apache.org> on 2018/04/01 14:08:00 UTC

[jira] [Comment Edited] (SOLR-8998) JSON Facet API child roll-ups

    [ https://issues.apache.org/jira/browse/SOLR-8998?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16421667#comment-16421667 ] 

Mikhail Khludnev edited comment on SOLR-8998 at 4/1/18 2:07 PM:
----------------------------------------------------------------

Thank you,  [~osavrasov]. The feasible syntax is a challenge. I suppose that those who need {{rollup}} (parent's count) doesn't need {{count}} (children's one). I propose to introduce the special facet {{type:termsUnique}} or {{type:termsDedupe}} or what's the better name here? Also, I want to start from passing a field or func values, rather than filter query, to mimic existing solution {{unique(\_root_)}}. ie 

{code}
"sku_colors_in_prods":{
    "type" : "termsUnique",
    "field" : "COLOR_s",
    "uniqueVal": "_root_",
    "domain" : {
        "blockChildren":"type:product"
    }
}
{code}

[~yseeley@gmail.com], what do you think of this syntax? 


was (Author: mkhludnev):
Thank you,  [~osavrasov]. The feasible syntax is a challenge. I suppose that those who need {{rollup}} (parent's count) doesn't need {{count}} (children's one). I propose to introduce the special facet {{type:termsUnique}} or {{type:termsDedupe}} or what's the better name here? Also, I want to start from passing a field or func values, rather than filter query, to mimic existing solution {{unique(\_root_)}}. ie 
{{code}}
"sku_colors_in_prods":{
    "type" : "termsUnique",
    "field" : "COLOR_s",
    "uniqueVal": "_root_",
    "domain" : {
        "blockChildren":"type:product"
    }
}
{{code}} 
[~yseeley@gmail.com], what do you think of this syntax? 

> JSON Facet API child roll-ups
> -----------------------------
>
>                 Key: SOLR-8998
>                 URL: https://issues.apache.org/jira/browse/SOLR-8998
>             Project: Solr
>          Issue Type: New Feature
>          Components: Facet Module
>            Reporter: Yonik Seeley
>            Priority: Major
>         Attachments: SOLR_8998.patch, SOLR_8998.patch, SOLR_8998.patch
>
>
> The JSON Facet API currently has the ability to map between parents and children ( see http://yonik.com/solr-nested-objects/ )
> This issue is about adding a true rollup ability where parents would take on derived values from their children.  The most important part (and the most difficult part) will be the external API.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org