You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@avalon.apache.org by Berin Loritsch <bl...@apache.org> on 2001/10/30 21:46:30 UTC

Check this alternative to Loggable

I updated the Loggable proposal.  This provides a smooth upgrade to the
new Logger interface instead of the LogKit Logger implementation.

The AbstractLogger will perform the wrapping for you.

Let me know what you all think, as I want to get this in ASAP!

-- 

"Those who would trade liberty for
 temporary security deserve neither"
                - Benjamin Franklin

--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: Check this alternative to Loggable

Posted by Berin Loritsch <bl...@apache.org>.
Peter Donald wrote:
> 
> On Wed, 31 Oct 2001 07:46, Berin Loritsch wrote:
> > I updated the Loggable proposal.  This provides a smooth upgrade to the
> > new Logger interface instead of the LogKit Logger implementation.
> 
> By smooth you mean non backwards compayible and will break your existings
> systems ? ;)
> 
> I am fairly anti such a move. I would much much much prefer something like
> the following. This is binary compatible and will not force me to go through
> and change oodles of stuff.

Ok.  I will make this change either today or tomorrow.


> 
> interface LogAware
> {
>  void enableLogging( Logger );
> }
> 
> class abstract AbstractLogAware implements LogAware {}
> 
> I really don't think we should be breaking binary compatability in such a
> fundamental interface in a supposedly stable library.
> 
> > The AbstractLogger will perform the wrapping for you.
> >
> > Let me know what you all think, as I want to get this in ASAP!
> 
> --
> Cheers,
> 
> Pete
> 
> *------------------------------------------------------*
> |  Hlade's Law: If you have a difficult task, give it  |
> |     to a lazy person -- they will find an easier     |
> |                    way to do it.                     |
> *------------------------------------------------------*
> 
> --
> To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
> For additional commands, e-mail: <ma...@jakarta.apache.org>


-- 

"Those who would trade liberty for
 temporary security deserve neither"
                - Benjamin Franklin

--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: Check this alternative to Loggable

Posted by Peter Donald <do...@apache.org>.
On Wed, 31 Oct 2001 07:46, Berin Loritsch wrote:
> I updated the Loggable proposal.  This provides a smooth upgrade to the
> new Logger interface instead of the LogKit Logger implementation.

By smooth you mean non backwards compayible and will break your existings 
systems ? ;)

I am fairly anti such a move. I would much much much prefer something like 
the following. This is binary compatible and will not force me to go through 
and change oodles of stuff.

interface LogAware
{
 void enableLogging( Logger );
}

class abstract AbstractLogAware implements LogAware {}

I really don't think we should be breaking binary compatability in such a 
fundamental interface in a supposedly stable library.

> The AbstractLogger will perform the wrapping for you.
>
> Let me know what you all think, as I want to get this in ASAP!

-- 
Cheers,

Pete

*------------------------------------------------------*
|  Hlade's Law: If you have a difficult task, give it  |
|     to a lazy person -- they will find an easier     |
|                    way to do it.                     |
*------------------------------------------------------*


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


RE: Check this alternative to Loggable

Posted by Leo Sutic <le...@inspireinfrastructure.com>.
I am not eligible to vote, but I'd say +one million if I were. This is a
must-have.

/LS

> -----Original Message-----
> From: Berin Loritsch [mailto:bloritsch@apache.org]
> Sent: den 31 oktober 2001 15:22
> To: Avalon Developers List
> Subject: Re: Check this alternative to Loggable
>
>
> Peter Royal wrote:
> >
> > At 03:46 PM 10/30/2001 -0500, you wrote:
> > >I updated the Loggable proposal.  This provides a smooth upgrade to the
> > >new Logger interface instead of the LogKit Logger implementation.
> > >
> > >The AbstractLogger will perform the wrapping for you.
> > >
> > >Let me know what you all think, as I want to get this in ASAP!
> >
> > Where is the proposal?
> > -pete
>
> It is in ${jakarta-avalon}/src/proposal/logger-v2/
>
> --
>
> "Those who would trade liberty for
>  temporary security deserve neither"
>                 - Benjamin Franklin
>
> --
> To unsubscribe, e-mail:
> <ma...@jakarta.apache.org>
> For additional commands, e-mail:
<ma...@jakarta.apache.org>



--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


RE: Check this alternative to Loggable

Posted by Peter Royal <pr...@managingpartners.com>.
At 03:58 PM 10/31/2001 +0100, you wrote:
>         I'm looking at proposal/loggable-v2, which contains the setLogger
>operation.
>         Where is enableLogging operation you referenced?
>
>         public interface Loggable
>         {
>                 void setLogger( Logger logger );
>         }

http://cvs.apache.org/viewcvs/jakarta-avalon/src/proposal/loggable-v2/Loggable.java?rev=1.2&content-type=text/vnd.viewcvs-markup

setLogger is deprecated in favor of enableLogging.
-pete

-- 
peter royal -> proyal@managingpartners.com
managing partners, inc. -> http://www.managingpartners.com


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: Check this alternative to Loggable

Posted by Peter Royal <pr...@managingpartners.com>.
At 10:05 AM 10/31/2001 -0500, you wrote:
>Although, we can have both methods named setLogger().
>
>That way, if folks do not have to rewrite anything--just
>change the import statement for Logger.

That'd be nice. I'm a lazy programmer :)
-pete

-- 
peter royal -> proyal@managingpartners.com
managing partners, inc. -> http://www.managingpartners.com


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


RE: Check this alternative to Loggable

Posted by Stephen McConnell <mc...@osm.net>.
Berin Loritsch wrote:
> Peter Royal wrote:
> > 
> > At 09:21 AM 10/31/2001 -0500, you wrote:
> > >It is in ${jakarta-avalon}/src/proposal/logger-v2/
> > 
> > ah, i was looking in ${jakarta-avalon}/proposal.
> > 
> > Why did you rename setLogger to enableLogging?  Just to prevent 
> > confusion?
> > 
> > otherwise looks good from the peanut gallery.
> > -pete
> 
> The main gist of the proposal is to migrate from using the
> LogKit Logger to the Logger interface included in Avalon
> Framework.  So yes, it is to prevent confusion.
> 
> Although, we can have both methods named setLogger().
> 
> That way, if folks do not have to rewrite anything--just
> change the import statement for Logger.

I would definately prefer to stay with "setLogger" for two reasons,
firstly, the change impact is less, and secondly, I don't see any 
confusion here.

Cheers, Steve.




--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: Check this alternative to Loggable

Posted by Berin Loritsch <bl...@apache.org>.
Peter Royal wrote:
> 
> At 09:21 AM 10/31/2001 -0500, you wrote:
> >It is in ${jakarta-avalon}/src/proposal/logger-v2/
> 
> ah, i was looking in ${jakarta-avalon}/proposal.
> 
> Why did you rename setLogger to enableLogging?  Just to prevent confusion?
> 
> otherwise looks good from the peanut gallery.
> -pete

The main gist of the proposal is to migrate from using the
LogKit Logger to the Logger interface included in Avalon
Framework.  So yes, it is to prevent confusion.

Although, we can have both methods named setLogger().

That way, if folks do not have to rewrite anything--just
change the import statement for Logger.

--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


RE: Check this alternative to Loggable

Posted by Stephen McConnell <mc...@osm.net>.

> -----Original Message-----
> From: Peter Royal [mailto:proyal@managingpartners.com]
> Sent: Wednesday, 31 October, 2001 15:41
> To: Avalon Developers List
> Subject: Re: Check this alternative to Loggable
>
>
> At 09:21 AM 10/31/2001 -0500, you wrote:
> >It is in ${jakarta-avalon}/src/proposal/logger-v2/
>
> ah, i was looking in ${jakarta-avalon}/proposal.
>
> Why did you rename setLogger to enableLogging?  Just to prevent confusion?


	I'm looking at proposal/loggable-v2, which contains the setLogger
operation.
	Where is enableLogging operation you referenced?

	public interface Loggable
	{
    		void setLogger( Logger logger );
	}

	Steve.


> otherwise looks good from the peanut gallery.
> -pete
>
>
>
> --
> peter royal -> proyal@managingpartners.com
> managing partners, inc. -> http://www.managingpartners.com
>
>
> --
> To unsubscribe, e-mail:
> <ma...@jakarta.apache.org>
> For additional commands, e-mail:
> <ma...@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: Check this alternative to Loggable

Posted by Peter Royal <pr...@managingpartners.com>.
At 09:21 AM 10/31/2001 -0500, you wrote:
>It is in ${jakarta-avalon}/src/proposal/logger-v2/

ah, i was looking in ${jakarta-avalon}/proposal.

Why did you rename setLogger to enableLogging?  Just to prevent confusion?

otherwise looks good from the peanut gallery.
-pete



-- 
peter royal -> proyal@managingpartners.com
managing partners, inc. -> http://www.managingpartners.com


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: Check this alternative to Loggable

Posted by Berin Loritsch <bl...@apache.org>.
Peter Royal wrote:
> 
> At 03:46 PM 10/30/2001 -0500, you wrote:
> >I updated the Loggable proposal.  This provides a smooth upgrade to the
> >new Logger interface instead of the LogKit Logger implementation.
> >
> >The AbstractLogger will perform the wrapping for you.
> >
> >Let me know what you all think, as I want to get this in ASAP!
> 
> Where is the proposal?
> -pete

It is in ${jakarta-avalon}/src/proposal/logger-v2/

-- 

"Those who would trade liberty for
 temporary security deserve neither"
                - Benjamin Franklin

--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: Check this alternative to Loggable

Posted by Peter Royal <pr...@managingpartners.com>.
At 03:46 PM 10/30/2001 -0500, you wrote:
>I updated the Loggable proposal.  This provides a smooth upgrade to the
>new Logger interface instead of the LogKit Logger implementation.
>
>The AbstractLogger will perform the wrapping for you.
>
>Let me know what you all think, as I want to get this in ASAP!

Where is the proposal?
-pete

-- 
peter royal -> proyal@managingpartners.com
managing partners, inc. -> http://www.managingpartners.com


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>