You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@mesos.apache.org by "Jay Buffington (JIRA)" <ji...@apache.org> on 2014/10/30 17:44:36 UTC
[jira] [Created] (MESOS-2016) docker_name_prefix is too generic
Jay Buffington created MESOS-2016:
-------------------------------------
Summary: docker_name_prefix is too generic
Key: MESOS-2016
URL: https://issues.apache.org/jira/browse/MESOS-2016
Project: Mesos
Issue Type: Bug
Reporter: Jay Buffington
>From docker.hpp and docker.cpp:
{quote}
// Prefix used to name Docker containers in order to distinguish those
// created by Mesos from those created manually.
extern std::string DOCKER_NAME_PREFIX;
// TODO(benh): At some point to run multiple slaves we'll need to make
// the Docker container name creation include the slave ID.
string DOCKER_NAME_PREFIX = "mesos-";
{quote}
This name is too generic. A common pattern in docker land is to run everything in a container and use volume mounts to share sockets do RPC between containers. CoreOS has popularized this technique.
Inevitably, what people do is start a container named "mesos-slave" which runs the docker containerizer recovery code which removes all containers that start with "mesos-" And then ask "huh, why did my mesos-slave docker container die? I don't see any error messages..."
Ideally, we should do what Ben suggested and add the slave id to the name prefix.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)