You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@usergrid.apache.org by ro...@apache.org on 2015/01/12 19:13:26 UTC

[06/17] incubator-usergrid git commit: Adding in the users call to management

Adding in the users call to management


Project: http://git-wip-us.apache.org/repos/asf/incubator-usergrid/repo
Commit: http://git-wip-us.apache.org/repos/asf/incubator-usergrid/commit/bd66715a
Tree: http://git-wip-us.apache.org/repos/asf/incubator-usergrid/tree/bd66715a
Diff: http://git-wip-us.apache.org/repos/asf/incubator-usergrid/diff/bd66715a

Branch: refs/heads/two-dot-o
Commit: bd66715af064ea67026b73c76f4d28671209490d
Parents: 5a59dea
Author: grey <gr...@apigee.com>
Authored: Tue Dec 23 14:13:17 2014 -0800
Committer: grey <gr...@apigee.com>
Committed: Tue Dec 23 14:13:17 2014 -0800

----------------------------------------------------------------------
 .../usergrid/rest/management/OrganizationsIT.java    | 10 +++++++---
 .../endpoints/mgmt/UsersResource.java                | 15 +++++++++++++--
 2 files changed, 20 insertions(+), 5 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/incubator-usergrid/blob/bd66715a/stack/rest/src/test/java/org/apache/usergrid/rest/management/OrganizationsIT.java
----------------------------------------------------------------------
diff --git a/stack/rest/src/test/java/org/apache/usergrid/rest/management/OrganizationsIT.java b/stack/rest/src/test/java/org/apache/usergrid/rest/management/OrganizationsIT.java
index 6ccaab1..aae2735 100644
--- a/stack/rest/src/test/java/org/apache/usergrid/rest/management/OrganizationsIT.java
+++ b/stack/rest/src/test/java/org/apache/usergrid/rest/management/OrganizationsIT.java
@@ -276,7 +276,6 @@ public class OrganizationsIT extends AbstractRestIT {
             assertEquals(500,uie.getResponse().getStatus());
            // assertEquals( ClientResponse.Status.NOT_IMPLEMENTED ,uie.getResponse().getStatus());
         }
-
     }
 
 
@@ -304,8 +303,13 @@ public class OrganizationsIT extends AbstractRestIT {
         assertNotNull( adminUserResponse );
         assertEquals( username, adminUserResponse.get( "username" ) );
 
-        Entity adminUserGetResponse = restClient.management().orgs().organization( clientSetup.getOrganizationName() )
-                                                .users()//needs an additional endpoint here
+        adminUserResponse = restClient.management().orgs().organization( clientSetup.getOrganizationName() )
+                                                .users().entity( username ).get();
+
+        assertNotNull( adminUserResponse );
+        assertEquals( username , adminUserResponse.get( "username" ) );
+        assertEquals( username, adminUserResponse.get( "name" ) );
+        assertEquals( username, adminUserResponse.get( "email" ));
 
 //        Map<String, String> payload = hashMap( "username", "test-user-2" ).map( "name", "Test User 2" )
 //                                                                          .map( "email", "test-user-2@mockserver.com" )

http://git-wip-us.apache.org/repos/asf/incubator-usergrid/blob/bd66715a/stack/rest/src/test/java/org/apache/usergrid/rest/test/resource2point0/endpoints/mgmt/UsersResource.java
----------------------------------------------------------------------
diff --git a/stack/rest/src/test/java/org/apache/usergrid/rest/test/resource2point0/endpoints/mgmt/UsersResource.java b/stack/rest/src/test/java/org/apache/usergrid/rest/test/resource2point0/endpoints/mgmt/UsersResource.java
index 7c79977..df3f3c1 100644
--- a/stack/rest/src/test/java/org/apache/usergrid/rest/test/resource2point0/endpoints/mgmt/UsersResource.java
+++ b/stack/rest/src/test/java/org/apache/usergrid/rest/test/resource2point0/endpoints/mgmt/UsersResource.java
@@ -20,11 +20,11 @@ package org.apache.usergrid.rest.test.resource2point0.endpoints.mgmt;
 
 import javax.ws.rs.core.MediaType;
 
+import org.apache.usergrid.rest.test.resource2point0.endpoints.EntityEndpoint;
 import org.apache.usergrid.rest.test.resource2point0.endpoints.NamedResource;
 import org.apache.usergrid.rest.test.resource2point0.endpoints.UrlResource;
 import org.apache.usergrid.rest.test.resource2point0.model.ApiResponse;
 import org.apache.usergrid.rest.test.resource2point0.model.Entity;
-import org.apache.usergrid.rest.test.resource2point0.model.User;
 import org.apache.usergrid.rest.test.resource2point0.state.ClientContext;
 
 import com.sun.jersey.api.client.WebResource;
@@ -39,9 +39,20 @@ public class UsersResource extends NamedResource {
         super( "users", context, parent );
     }
 
+
+    /**
+     * Should this be here? this would facilitate calling the entity endpoint as a way to get/put things
+     * @param identifier
+     * @return
+     */
+    //TODO: See if this should be reused here or if we should rename it to something else.
+    public EntityEndpoint entity(String identifier) {
+        return new EntityEndpoint(identifier, context, this);
+    }
+
     public Entity post(Entity userPayload){
         WebResource resource = getResource(true);
-
+//TODO: need to parse the specific response gotten for admin entities. It is different from regular entities.
         ApiResponse response = resource.type( MediaType.APPLICATION_JSON_TYPE )
                 .accept( MediaType.APPLICATION_JSON ).post( ApiResponse.class, userPayload);
         return new Entity(response);