You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@couchdb.apache.org by "Randall Leeds (JIRA)" <ji...@apache.org> on 2011/04/23 02:56:05 UTC

[jira] [Created] (COUCHDB-1137) add delete options for controlling file deletion

add delete options for controlling file deletion
------------------------------------------------

                 Key: COUCHDB-1137
                 URL: https://issues.apache.org/jira/browse/COUCHDB-1137
             Project: CouchDB
          Issue Type: Improvement
          Components: Database Core
    Affects Versions: 1.0.2
            Reporter: Randall Leeds
            Priority: Minor


Even after switching to an extents-based filesystem I've noticed that deleting files after compaction can sometimes be terribly painful and slow. Additionally, deleting large pre-compact database and view files places extra load on the server that may be best kept to off hours. These sorts of large databases might be impossible to run a complete compact cycle on in short time. I'm suggesting we add an option to allow couch to leave files to be deleted in the .delete directories so administrators can delete them at their leisure (presumably at off hours or with a tool like ionice).

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Updated] (COUCHDB-1137) add delete options for controlling file deletion

Posted by "Randall Leeds (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/COUCHDB-1137?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Randall Leeds updated COUCHDB-1137:
-----------------------------------

    Attachment: delete_options.patch

Patch add delete options. Currently just async and nodelete. nodelete might be a confusing name. I'm open to better suggestions.

> add delete options for controlling file deletion
> ------------------------------------------------
>
>                 Key: COUCHDB-1137
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1137
>             Project: CouchDB
>          Issue Type: Improvement
>          Components: Database Core
>    Affects Versions: 1.0.2
>            Reporter: Randall Leeds
>            Priority: Minor
>         Attachments: delete_options.patch, respect_del_opts_on_db_init.patch
>
>
> Even after switching to an extents-based filesystem I've noticed that deleting files after compaction can sometimes be terribly painful and slow. Additionally, deleting large pre-compact database and view files places extra load on the server that may be best kept to off hours. These sorts of large databases might be impossible to run a complete compact cycle on in short time. I'm suggesting we add an option to allow couch to leave files to be deleted in the .delete directories so administrators can delete them at their leisure (presumably at off hours or with a tool like ionice).

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Assigned] (COUCHDB-1137) add delete options for controlling file deletion

Posted by "Randall Leeds (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/COUCHDB-1137?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Randall Leeds reassigned COUCHDB-1137:
--------------------------------------

    Assignee: Randall Leeds

> add delete options for controlling file deletion
> ------------------------------------------------
>
>                 Key: COUCHDB-1137
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1137
>             Project: CouchDB
>          Issue Type: Improvement
>          Components: Database Core
>    Affects Versions: 1.0.2
>            Reporter: Randall Leeds
>            Assignee: Randall Leeds
>            Priority: Minor
>         Attachments: delete_options.patch, respect_del_opts_on_db_init.patch
>
>
> Even after switching to an extents-based filesystem I've noticed that deleting files after compaction can sometimes be terribly painful and slow. Additionally, deleting large pre-compact database and view files places extra load on the server that may be best kept to off hours. These sorts of large databases might be impossible to run a complete compact cycle on in short time. I'm suggesting we add an option to allow couch to leave files to be deleted in the .delete directories so administrators can delete them at their leisure (presumably at off hours or with a tool like ionice).

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Updated] (COUCHDB-1137) add delete options for controlling file deletion

Posted by "Randall Leeds (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/COUCHDB-1137?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Randall Leeds updated COUCHDB-1137:
-----------------------------------

    Attachment: respect_del_opts_on_db_init.patch

One clause of couch_db_updater:init/1 was calling file:delete directly to remove old .compact files. I didn't see any reason for this so I unified the code and it will now respect the delete options patch here as a result.

> add delete options for controlling file deletion
> ------------------------------------------------
>
>                 Key: COUCHDB-1137
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1137
>             Project: CouchDB
>          Issue Type: Improvement
>          Components: Database Core
>    Affects Versions: 1.0.2
>            Reporter: Randall Leeds
>            Priority: Minor
>         Attachments: delete_options.patch, respect_del_opts_on_db_init.patch
>
>
> Even after switching to an extents-based filesystem I've noticed that deleting files after compaction can sometimes be terribly painful and slow. Additionally, deleting large pre-compact database and view files places extra load on the server that may be best kept to off hours. These sorts of large databases might be impossible to run a complete compact cycle on in short time. I'm suggesting we add an option to allow couch to leave files to be deleted in the .delete directories so administrators can delete them at their leisure (presumably at off hours or with a tool like ionice).

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Commented] (COUCHDB-1137) add delete options for controlling file deletion

Posted by "Randall Leeds (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/COUCHDB-1137?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13023477#comment-13023477 ] 

Randall Leeds commented on COUCHDB-1137:
----------------------------------------

Tests forthcoming in separate patch.

> add delete options for controlling file deletion
> ------------------------------------------------
>
>                 Key: COUCHDB-1137
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1137
>             Project: CouchDB
>          Issue Type: Improvement
>          Components: Database Core
>    Affects Versions: 1.0.2
>            Reporter: Randall Leeds
>            Priority: Minor
>         Attachments: delete_options.patch, respect_del_opts_on_db_init.patch
>
>
> Even after switching to an extents-based filesystem I've noticed that deleting files after compaction can sometimes be terribly painful and slow. Additionally, deleting large pre-compact database and view files places extra load on the server that may be best kept to off hours. These sorts of large databases might be impossible to run a complete compact cycle on in short time. I'm suggesting we add an option to allow couch to leave files to be deleted in the .delete directories so administrators can delete them at their leisure (presumably at off hours or with a tool like ionice).

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira