You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@accumulo.apache.org by "Michael Berman (JIRA)" <ji...@apache.org> on 2013/02/04 21:58:12 UTC

[jira] [Created] (ACCUMULO-1040) Variable name inconsistency in "Reading Data" client code snippet

Michael Berman created ACCUMULO-1040:
----------------------------------------

             Summary: Variable name inconsistency in "Reading Data" client code snippet
                 Key: ACCUMULO-1040
                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1040
             Project: Accumulo
          Issue Type: Bug
          Components: docs
    Affects Versions: 1.4.2
            Reporter: Michael Berman
            Assignee: David Medinets
            Priority: Critical


On the "Writing Clients" doc page, in the section "SCANNER" (at http://accumulo.apache.org/1.4/user_manual/Writing_Accumulo_Clients.html#Reading_Data), there is the following code snippet:

{code}
for(Entry<Key,Value> entry : scan) {
    String row = e.getKey().getRow();
    Value value = e.getValue();
}
{code}

In the loop body, {{e}} should be {{entry}}.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira