You are viewing a plain text version of this content. The canonical link for it is here.
Posted to j-dev@xerces.apache.org by "SingingBush (via GitHub)" <gi...@apache.org> on 2025/11/10 08:54:28 UTC
[PR] [XERCESJ-1781] Javadoc fixes for html in org.apache.xerces [xerces-j]
SingingBush opened a new pull request, #47:
URL: https://github.com/apache/xerces-j/pull/47
Some more html fixes for errors in Javadoc generation. Mostly handling chars like `<` and `&` correctly. Not that tables need to have a `caption` tag. I've left it blank as there was previously no caption anyway. This at least prevents html errors in Javadoc.
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: j-dev-unsubscribe@xerces.apache.org
For queries about this service, please contact Infrastructure at:
users@infra.apache.org
---------------------------------------------------------------------
To unsubscribe, e-mail: j-dev-unsubscribe@xerces.apache.org
For additional commands, e-mail: j-dev-help@xerces.apache.org
Re: [PR] [XERCESJ-1781] Javadoc fixes for html in org.apache.xerces [xerces-j]
Posted by "SingingBush (via GitHub)" <gi...@apache.org>.
SingingBush commented on PR #47:
URL: https://github.com/apache/xerces-j/pull/47#issuecomment-3514457342
> Near as I can tell captions on tables are not required in both XHTML 1.0 and the "Living Standard". They're recommended but not with empty content
yeah, it's odd that the Javadoc linter has been set to treat the lack of a captions block as an error
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: j-dev-unsubscribe@xerces.apache.org
For queries about this service, please contact Infrastructure at:
users@infra.apache.org
---------------------------------------------------------------------
To unsubscribe, e-mail: j-dev-unsubscribe@xerces.apache.org
For additional commands, e-mail: j-dev-help@xerces.apache.org
Re: [PR] [XERCESJ-1781] Javadoc fixes for html in org.apache.xerces [xerces-j]
Posted by "SingingBush (via GitHub)" <gi...@apache.org>.
SingingBush commented on code in PR #47:
URL: https://github.com/apache/xerces-j/pull/47#discussion_r2526542859
##########
src/org/apache/xerces/impl/XMLScanner.java:
##########
@@ -770,9 +772,13 @@ else if (isInvalidLiteral(c)) {
/**
* Scans an attribute value and normalizes whitespace converting all
* whitespace characters to space characters.
- * <p>
- * <code>[10] AttValue ::= '"' ([^<&"] | Reference)* '"' | "'" ([^<&'] | Reference)* "'"</code>
- * </p>
+ * <pre>
Review Comment:
updated
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: j-dev-unsubscribe@xerces.apache.org
For queries about this service, please contact Infrastructure at:
users@infra.apache.org
---------------------------------------------------------------------
To unsubscribe, e-mail: j-dev-unsubscribe@xerces.apache.org
For additional commands, e-mail: j-dev-help@xerces.apache.org
Re: [PR] [XERCESJ-1781] Javadoc fixes for html in org.apache.xerces [xerces-j]
Posted by "elharo (via GitHub)" <gi...@apache.org>.
elharo commented on code in PR #47:
URL: https://github.com/apache/xerces-j/pull/47#discussion_r2512065105
##########
src/org/apache/xerces/util/URI.java:
##########
@@ -1783,7 +1783,7 @@ public static boolean isConformantSchemeName(String p_scheme) {
* '.'. Each group must consist of one to three digits. See RFC 2732 Section 3,
* and RFC 2373 Section 2.2, for the definition of IPv6 references. A hostname
* consists of domain labels (each of which must begin and end with an alphanumeric
- * but may contain '-') separated & by a '.'. See RFC 2396 Section 3.2.2.
+ * but may contain '-') separated & by a '.'. See RFC 2396 Section 3.2.2.
Review Comment:
This comment is somehow wrong. I'm not sure exactly how to fix it or what was intended here. It's possible we don't need the ampersand here at all.
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: j-dev-unsubscribe@xerces.apache.org
For queries about this service, please contact Infrastructure at:
users@infra.apache.org
---------------------------------------------------------------------
To unsubscribe, e-mail: j-dev-unsubscribe@xerces.apache.org
For additional commands, e-mail: j-dev-help@xerces.apache.org
Re: [PR] [XERCESJ-1781] Javadoc fixes for html in org.apache.xerces [xerces-j]
Posted by "elharo (via GitHub)" <gi...@apache.org>.
elharo commented on code in PR #47:
URL: https://github.com/apache/xerces-j/pull/47#discussion_r2525159674
##########
src/org/apache/xerces/impl/XMLScanner.java:
##########
@@ -770,9 +772,13 @@ else if (isInvalidLiteral(c)) {
/**
* Scans an attribute value and normalizes whitespace converting all
* whitespace characters to space characters.
- * <p>
- * <code>[10] AttValue ::= '"' ([^<&"] | Reference)* '"' | "'" ([^<&'] | Reference)* "'"</code>
- * </p>
+ * <pre>
Review Comment:
I think p is more appropriate than pre here. Whitespace can be collapsed here
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: j-dev-unsubscribe@xerces.apache.org
For queries about this service, please contact Infrastructure at:
users@infra.apache.org
---------------------------------------------------------------------
To unsubscribe, e-mail: j-dev-unsubscribe@xerces.apache.org
For additional commands, e-mail: j-dev-help@xerces.apache.org
Re: [PR] [XERCESJ-1781] Javadoc fixes for html in org.apache.xerces [xerces-j]
Posted by "elharo (via GitHub)" <gi...@apache.org>.
elharo merged PR #47:
URL: https://github.com/apache/xerces-j/pull/47
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: j-dev-unsubscribe@xerces.apache.org
For queries about this service, please contact Infrastructure at:
users@infra.apache.org
---------------------------------------------------------------------
To unsubscribe, e-mail: j-dev-unsubscribe@xerces.apache.org
For additional commands, e-mail: j-dev-help@xerces.apache.org
Re: [PR] [XERCESJ-1781] Javadoc fixes for html in org.apache.xerces [xerces-j]
Posted by "SingingBush (via GitHub)" <gi...@apache.org>.
SingingBush commented on PR #47:
URL: https://github.com/apache/xerces-j/pull/47#issuecomment-3526452476
> You need to remove the empty captions
I'll push another commit that reverts them. That will of course leave errors such as:
```
[javadoc] /home/user/apache/xerces-j/build/src/org/apache/xerces/xs/datatypes/package.html:220: error: no caption for table
[javadoc] </TABLE>
[javadoc] ^
```
I'd recommend going the other way and just deciding on some text to use in the caption.
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: j-dev-unsubscribe@xerces.apache.org
For queries about this service, please contact Infrastructure at:
users@infra.apache.org
---------------------------------------------------------------------
To unsubscribe, e-mail: j-dev-unsubscribe@xerces.apache.org
For additional commands, e-mail: j-dev-help@xerces.apache.org
Re: [PR] [XERCESJ-1781] Javadoc fixes for html in org.apache.xerces [xerces-j]
Posted by "SingingBush (via GitHub)" <gi...@apache.org>.
SingingBush commented on code in PR #47:
URL: https://github.com/apache/xerces-j/pull/47#discussion_r2512371586
##########
src/org/apache/xerces/util/URI.java:
##########
@@ -1783,7 +1783,7 @@ public static boolean isConformantSchemeName(String p_scheme) {
* '.'. Each group must consist of one to three digits. See RFC 2732 Section 3,
* and RFC 2373 Section 2.2, for the definition of IPv6 references. A hostname
* consists of domain labels (each of which must begin and end with an alphanumeric
- * but may contain '-') separated & by a '.'. See RFC 2396 Section 3.2.2.
+ * but may contain '-') separated & by a '.'. See RFC 2396 Section 3.2.2.
Review Comment:
good spot, I was focused on just sorting the error and did't read it. I'll remove the ampersand
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: j-dev-unsubscribe@xerces.apache.org
For queries about this service, please contact Infrastructure at:
users@infra.apache.org
---------------------------------------------------------------------
To unsubscribe, e-mail: j-dev-unsubscribe@xerces.apache.org
For additional commands, e-mail: j-dev-help@xerces.apache.org