You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@bookkeeper.apache.org by "Matteo Merli (JIRA)" <ji...@apache.org> on 2012/05/31 20:08:23 UTC

[jira] [Created] (BOOKKEEPER-280) LedgerHandle.addEntry() should return an entryId

Matteo Merli created BOOKKEEPER-280:
---------------------------------------

             Summary: LedgerHandle.addEntry() should return an entryId
                 Key: BOOKKEEPER-280
                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-280
             Project: Bookkeeper
          Issue Type: Bug
          Components: bookkeeper-client
    Affects Versions: 4.2.0
            Reporter: Matteo Merli
            Priority: Minor
             Fix For: 4.2.0


LedgerHandle.asyncAddEntry callback provides the entryId of the newly added entry, but the synchronous version return void. 


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (BOOKKEEPER-280) LedgerHandle.addEntry() should return an entryId

Posted by "Sijie Guo (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/BOOKKEEPER-280?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13401976#comment-13401976 ] 

Sijie Guo commented on BOOKKEEPER-280:
--------------------------------------

I am OK for the binary compability. +1 for the patch.
                
> LedgerHandle.addEntry() should return an entryId
> ------------------------------------------------
>
>                 Key: BOOKKEEPER-280
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-280
>             Project: Bookkeeper
>          Issue Type: Bug
>          Components: bookkeeper-client
>    Affects Versions: 4.2.0
>            Reporter: Matteo Merli
>            Assignee: Matteo Merli
>            Priority: Minor
>             Fix For: 4.2.0
>
>         Attachments: 0001-BOOKKEEPER-280-LedgerHandle.addEntry-should-return-a.patch, 0001-BOOKKEEPER-280-LedgerHandle.addEntry-should-return-a.patch
>
>
> LedgerHandle.asyncAddEntry callback provides the entryId of the newly added entry, but the synchronous version return void. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (BOOKKEEPER-280) LedgerHandle.addEntry() should return an entryId

Posted by "Matteo Merli (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/BOOKKEEPER-280?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Matteo Merli updated BOOKKEEPER-280:
------------------------------------

    Attachment: 0001-BOOKKEEPER-280-LedgerHandle.addEntry-should-return-a.patch
    
> LedgerHandle.addEntry() should return an entryId
> ------------------------------------------------
>
>                 Key: BOOKKEEPER-280
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-280
>             Project: Bookkeeper
>          Issue Type: Bug
>          Components: bookkeeper-client
>    Affects Versions: 4.2.0
>            Reporter: Matteo Merli
>            Priority: Minor
>             Fix For: 4.2.0
>
>         Attachments: 0001-BOOKKEEPER-280-LedgerHandle.addEntry-should-return-a.patch
>
>
> LedgerHandle.asyncAddEntry callback provides the entryId of the newly added entry, but the synchronous version return void. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (BOOKKEEPER-280) LedgerHandle.addEntry() should return an entryId

Posted by "Sijie Guo (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/BOOKKEEPER-280?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13287129#comment-13287129 ] 

Sijie Guo commented on BOOKKEEPER-280:
--------------------------------------

[~mmerli] the patch seems good to me. only one place, it would be better to change -1 to use a constant define in "long entryId = -1;". The constant define you could refer BOOKKEEPER-260.

But one thing that I concerned is that changing return value breaks binary compatibility (i.e. bytecodes that was previously compiled against the old API will no longer run).
http://stackoverflow.com/questions/3589946/retrofitting-void-methods-to-return-its-argument-to-facilitate-fluency-breaking

In order not to block BOOKKEEPER-220, I would suggest you implement sync addEntry based on bookkeeper's asyncAddEntry first to get the entry id.
                
> LedgerHandle.addEntry() should return an entryId
> ------------------------------------------------
>
>                 Key: BOOKKEEPER-280
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-280
>             Project: Bookkeeper
>          Issue Type: Bug
>          Components: bookkeeper-client
>    Affects Versions: 4.2.0
>            Reporter: Matteo Merli
>            Priority: Minor
>             Fix For: 4.2.0
>
>         Attachments: 0001-BOOKKEEPER-280-LedgerHandle.addEntry-should-return-a.patch, 0001-BOOKKEEPER-280-LedgerHandle.addEntry-should-return-a.patch
>
>
> LedgerHandle.asyncAddEntry callback provides the entryId of the newly added entry, but the synchronous version return void. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (BOOKKEEPER-280) LedgerHandle.addEntry() should return an entryId

Posted by "Ivan Kelly (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/BOOKKEEPER-280?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13294339#comment-13294339 ] 

Ivan Kelly commented on BOOKKEEPER-280:
---------------------------------------

Patch looks fine except for the magic number Sijie mentioned. 

Re: binary compability, I think it's fine to break, as people tend to recompile when they dump a dependency version anyhow. Its source compatibility we need to worry about, and compatibility between nodes running different versions.
                
> LedgerHandle.addEntry() should return an entryId
> ------------------------------------------------
>
>                 Key: BOOKKEEPER-280
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-280
>             Project: Bookkeeper
>          Issue Type: Bug
>          Components: bookkeeper-client
>    Affects Versions: 4.2.0
>            Reporter: Matteo Merli
>            Priority: Minor
>             Fix For: 4.2.0
>
>         Attachments: 0001-BOOKKEEPER-280-LedgerHandle.addEntry-should-return-a.patch, 0001-BOOKKEEPER-280-LedgerHandle.addEntry-should-return-a.patch
>
>
> LedgerHandle.asyncAddEntry callback provides the entryId of the newly added entry, but the synchronous version return void. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (BOOKKEEPER-280) LedgerHandle.addEntry() should return an entryId

Posted by "Matteo Merli (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/BOOKKEEPER-280?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Matteo Merli updated BOOKKEEPER-280:
------------------------------------

    Attachment: 0001-BOOKKEEPER-280-LedgerHandle.addEntry-should-return-a.patch
    
> LedgerHandle.addEntry() should return an entryId
> ------------------------------------------------
>
>                 Key: BOOKKEEPER-280
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-280
>             Project: Bookkeeper
>          Issue Type: Bug
>          Components: bookkeeper-client
>    Affects Versions: 4.2.0
>            Reporter: Matteo Merli
>            Priority: Minor
>             Fix For: 4.2.0
>
>         Attachments: 0001-BOOKKEEPER-280-LedgerHandle.addEntry-should-return-a.patch, 0001-BOOKKEEPER-280-LedgerHandle.addEntry-should-return-a.patch
>
>
> LedgerHandle.asyncAddEntry callback provides the entryId of the newly added entry, but the synchronous version return void. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (BOOKKEEPER-280) LedgerHandle.addEntry() should return an entryId

Posted by "Matteo Merli (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/BOOKKEEPER-280?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Matteo Merli updated BOOKKEEPER-280:
------------------------------------

    Attachment: 0001-BOOKKEEPER-220-Managed-Ledger-proposal.patch
    
> LedgerHandle.addEntry() should return an entryId
> ------------------------------------------------
>
>                 Key: BOOKKEEPER-280
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-280
>             Project: Bookkeeper
>          Issue Type: Bug
>          Components: bookkeeper-client
>    Affects Versions: 4.2.0
>            Reporter: Matteo Merli
>            Assignee: Matteo Merli
>            Priority: Minor
>             Fix For: 4.2.0
>
>         Attachments: 0001-BOOKKEEPER-280-LedgerHandle.addEntry-should-return-a.patch, 0001-BOOKKEEPER-280-LedgerHandle.addEntry-should-return-a.patch
>
>
> LedgerHandle.asyncAddEntry callback provides the entryId of the newly added entry, but the synchronous version return void. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (BOOKKEEPER-280) LedgerHandle.addEntry() should return an entryId

Posted by "Hudson (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/BOOKKEEPER-280?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13404031#comment-13404031 ] 

Hudson commented on BOOKKEEPER-280:
-----------------------------------

Integrated in bookkeeper-trunk #585 (See [https://builds.apache.org/job/bookkeeper-trunk/585/])
    BOOKKEEPER-280: LedgerHandle.addEntry() should return an entryId (mmerli via ivank) (Revision 1355467)

     Result = UNSTABLE
ivank : 
Files : 
* /zookeeper/bookkeeper/trunk/CHANGES.txt
* /zookeeper/bookkeeper/trunk/bookkeeper-server/src/main/java/org/apache/bookkeeper/client/LedgerHandle.java
* /zookeeper/bookkeeper/trunk/bookkeeper-server/src/main/java/org/apache/bookkeeper/client/ReadOnlyLedgerHandle.java

                
> LedgerHandle.addEntry() should return an entryId
> ------------------------------------------------
>
>                 Key: BOOKKEEPER-280
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-280
>             Project: Bookkeeper
>          Issue Type: Bug
>          Components: bookkeeper-client
>    Affects Versions: 4.2.0
>            Reporter: Matteo Merli
>            Assignee: Matteo Merli
>            Priority: Minor
>             Fix For: 4.2.0
>
>         Attachments: 0001-BOOKKEEPER-280-LedgerHandle.addEntry-should-return-a.patch, 0001-BOOKKEEPER-280-LedgerHandle.addEntry-should-return-a.patch
>
>
> LedgerHandle.asyncAddEntry callback provides the entryId of the newly added entry, but the synchronous version return void. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (BOOKKEEPER-280) LedgerHandle.addEntry() should return an entryId

Posted by "Matteo Merli (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/BOOKKEEPER-280?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Matteo Merli updated BOOKKEEPER-280:
------------------------------------

    Attachment:     (was: 0001-BOOKKEEPER-220-Managed-Ledger-proposal.patch)
    
> LedgerHandle.addEntry() should return an entryId
> ------------------------------------------------
>
>                 Key: BOOKKEEPER-280
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-280
>             Project: Bookkeeper
>          Issue Type: Bug
>          Components: bookkeeper-client
>    Affects Versions: 4.2.0
>            Reporter: Matteo Merli
>            Assignee: Matteo Merli
>            Priority: Minor
>             Fix For: 4.2.0
>
>         Attachments: 0001-BOOKKEEPER-280-LedgerHandle.addEntry-should-return-a.patch, 0001-BOOKKEEPER-280-LedgerHandle.addEntry-should-return-a.patch
>
>
> LedgerHandle.asyncAddEntry callback provides the entryId of the newly added entry, but the synchronous version return void. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira