You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-issues@hadoop.apache.org by "Kihwal Lee (Commented) (JIRA)" <ji...@apache.org> on 2011/10/27 12:36:33 UTC

[jira] [Commented] (HADOOP-7360) FsShell does not preserve relative paths with globs

    [ https://issues.apache.org/jira/browse/HADOOP-7360?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13136951#comment-13136951 ] 

Kihwal Lee commented on HADOOP-7360:
------------------------------------

bq. 1. CopyCommands#Get: class instance variable LocalFileSystem localFs is no longer...
Deleted.

bq. 2. PathData.toFile()
A check has been added to make sure it is LocalFileSystem. Otherwise an IllegalArgumentException is thrown.

bq. 3. PathData.toString()
Comment corrected. Actually toString() is okay. The problem was creating the URI. Added a static method to parse and extract each uri component from input string.  It is slightly different from what is done in Path.

bq. 4. In PathData ctors, the use of URI.create() may throw undeclared RuntimeExceptions.
The ctor now throws IOException.

bq. 5. In main ctor, I'm very happy that this.path is initialized to a fully qualified path. Does this work correctly for files that don't exist yet?
I am too. And Yes.

bq. 6. lookupStat() should be changed to take path rather than pathString as its argument.
Changed as suggested. this.path is initialized before calling lookupStat() in ctors.

bq. 7. checkIfDirectory(boolean flag): Please change name of argument to "desiredResult" or ...
now using less confusing names.

bq. 8. getStringForChildPath(): if caller provides an absolute path, this won't behave right. ...
Relative or absolute, Path#getName() always returns the last component, so it won't matter.

bq. 9. PathType: It's actually "scheme" not "schema". And strictly speaking ...
Corrected as suggested.

bq. 10. expandAsGlob(): please use "cwd" ...
Corrected as suggested.

bq. 11. removeAuthority(): I don't understand the comment at the beginning of the method.
Removed. The comment applies to a different method in URI. A stale one, I guess.

                
> FsShell does not preserve relative paths with globs
> ---------------------------------------------------
>
>                 Key: HADOOP-7360
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7360
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: fs
>    Affects Versions: 0.23.0
>            Reporter: Daryn Sharp
>            Assignee: Kihwal Lee
>             Fix For: 0.23.0
>
>         Attachments: HADOOP-7360-2.patch, HADOOP-7360-3.patch, HADOOP-7360-4.patch, HADOOP-7360.patch, HADOOP-7360.txt
>
>
> FsShell currently preserves relative paths that do not contain globs.  Unfortunately the method {{fs.globStatus()}} is fully qualifying all returned paths.  This is causing inconsistent display of paths.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira