You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@openmeetings.apache.org by "seba.wagner@gmail.com" <se...@gmail.com> on 2012/10/14 14:13:22 UTC

Naming convention for Interfaces and Dao's

Hi,

I would like to propose the following naming conventions:

Interfaces start with an "I"

public interface IOmDao {
}

Implementations like the DaoImpl (Data Access Object Implementation)
will be renamed to Dao (without the Impl, there is no need to write "Impl"
if the Dao interface has the "I" in its name).

So the UserDaoImpl will be simply:
 UserDao implements IOmDao

And I would like to find a more meaningful name for "OmDao" and "OmEntity"..
It might be better to name those interfaces by its usage, cause the name
"OpenMeetings" might change and it does not say so much about the usage of
the interface.

Maybe something like "IPagingDao" or "IPaginationDao"
and the corresponding "OmEntity" to "IPagingEntity".

Sebastian

-- 
Sebastian Wagner
https://twitter.com/#!/dead_lock
http://www.webbase-design.de
http://www.wagner-sebastian.com
seba.wagner@gmail.com

Re: Naming convention for Interfaces and Dao's

Posted by "seba.wagner@gmail.com" <se...@gmail.com>.
True, those button are actually one of my first tryouts with Wicket, so
there is some space for improvements :)

Sebastian

2012/10/15 Maxim Solodovnik <so...@gmail.com>

> Alternative names:
> IDataProviderDAO
> IEntity (it has nothing connecting it to something pagable, so I'm sure
> should not be IPagableEntity)
>
> I also think
> we should use shorten names in cases like this:
>
> <input type="submit" value="System Import"
> wicket:id="ajax-backup-upload-button" />
> <!-- Perform Upload -->
> <input type="submit" value="System Backup"
> wicket:id="ajax-backup-download-button" />
>
> there are only 2 buttons on the whole page
> I would vote for naming it:
>
> <input type="submit" value="System Import" wicket:id="upload" />
> <!-- Perform Upload -->
> <input type="submit" value="System Backup" wicket:id="download" />
>
> Both markup and code clearly describes it as "button"s. Both markup and
> code file name contains "backup" in the name. And I'm sure it is not
> necessary to put "ajax" in the name.
>
> On Sun, Oct 14, 2012 at 11:02 PM, seba.wagner@gmail.com <
> seba.wagner@gmail.com> wrote:
>
> > >But I would vote for not creating IPagableEntity.
> > => Do you have an alternative name proposal?
> >
> > >Also we already has discussion regarding class renaming....
> > >Are we still planning to do it?
> > >Shall I handle it?*
> > => If you refer to this ones:
> > Users => User
> > Adresses => Address
> > States => State
> > ... et cetera.
> > It is still planned todo. But our code base is not stable enough
> currently.
> > We have enough instability :)
> > Renaming Entities will affect JPQL, a simple "eclipse refactoring" will
> not
> > fix this at all.
> > I would rather prefer to fix the Backup Export/Import, then create a
> > "master backup file" that contains a lot of the eventualities and that we
> > can use as reference for testing.
> > After that we can refactor Entities and table names and do test it with
> our
> > master backup file again.
> >
> > *do I need to take a look at your import/export issue or you going to
> > fix it yourself?*
> > => There are multiple issues here. Some queries don't work anymore
> because
> > of refactoring with Lazy Loading and there is a general issue with the
> XML
> > framework.
> > I think I will have a look at this issue by the start of this week.
> >
> > We also still have some open issues for the Admin area like search
> fields,
> > ordering of tables, creating/improving the CSS file for the layout of the
> > forms and grids.
> > And you are also already looking in howto bring WebSocket's and
> Atmosphere
> > Framework into our stack.
> > I think that is already a lot of stuff todo. We should complete
> components
> > before we move on and add new things.
> > Although I think your work regarding WebSockets/Tomcat7 and Atmosphere is
> > really useful as those features will be the next big thing to integrate.
> >
> > What do you think?
> >
> > Sebastian
> >
> > 2012/10/14 Maxim Solodovnik <so...@gmail.com>
> >
> > > Also we already has discussion regarding class renaming....
> > > Are we still planning to do it?
> > > Shall I handle it?
> > >
> > > BTW do I need to take a look at your import/export issue or you going
> to
> > > fix it yourself?
> > > On Oct 14, 2012 10:05 PM, "Maxim Solodovnik" <so...@gmail.com>
> > wrote:
> > >
> > > > I agree regarding interface and dao. But I would vote for not
> creating
> > > > IPagableEntity. My idea was to create something like absttact
> > > Identifiable,
> > > > add id field to it and getter and setter. (All our entities has id)
> > > > On Oct 14, 2012 7:14 PM, "seba.wagner@gmail.com" <
> > seba.wagner@gmail.com>
> > > > wrote:
> > > >
> > > >> Hi,
> > > >>
> > > >> I would like to propose the following naming conventions:
> > > >>
> > > >> Interfaces start with an "I"
> > > >>
> > > >> public interface IOmDao {
> > > >> }
> > > >>
> > > >> Implementations like the DaoImpl (Data Access Object Implementation)
> > > >> will be renamed to Dao (without the Impl, there is no need to write
> > > "Impl"
> > > >> if the Dao interface has the "I" in its name).
> > > >>
> > > >> So the UserDaoImpl will be simply:
> > > >>  UserDao implements IOmDao
> > > >>
> > > >> And I would like to find a more meaningful name for "OmDao" and
> > > >> "OmEntity"..
> > > >> It might be better to name those interfaces by its usage, cause the
> > name
> > > >> "OpenMeetings" might change and it does not say so much about the
> > usage
> > > of
> > > >> the interface.
> > > >>
> > > >> Maybe something like "IPagingDao" or "IPaginationDao"
> > > >> and the corresponding "OmEntity" to "IPagingEntity".
> > > >>
> > > >> Sebastian
> > > >>
> > > >> --
> > > >> Sebastian Wagner
> > > >> https://twitter.com/#!/dead_lock
> > > >> http://www.webbase-design.de
> > > >> http://www.wagner-sebastian.com
> > > >> seba.wagner@gmail.com
> > > >>
> > > >
> > >
> >
> >
> >
> > --
> > Sebastian Wagner
> > https://twitter.com/#!/dead_lock
> > http://www.webbase-design.de
> > http://www.wagner-sebastian.com
> > seba.wagner@gmail.com
> >
>
>
>
> --
> WBR
> Maxim aka solomax
>



-- 
Sebastian Wagner
https://twitter.com/#!/dead_lock
http://www.webbase-design.de
http://www.wagner-sebastian.com
seba.wagner@gmail.com

Re: Naming convention for Interfaces and Dao's

Posted by Maxim Solodovnik <so...@gmail.com>.
Alternative names:
IDataProviderDAO
IEntity (it has nothing connecting it to something pagable, so I'm sure
should not be IPagableEntity)

I also think
we should use shorten names in cases like this:

<input type="submit" value="System Import"
wicket:id="ajax-backup-upload-button" />
<!-- Perform Upload -->
<input type="submit" value="System Backup"
wicket:id="ajax-backup-download-button" />

there are only 2 buttons on the whole page
I would vote for naming it:

<input type="submit" value="System Import" wicket:id="upload" />
<!-- Perform Upload -->
<input type="submit" value="System Backup" wicket:id="download" />

Both markup and code clearly describes it as "button"s. Both markup and
code file name contains "backup" in the name. And I'm sure it is not
necessary to put "ajax" in the name.

On Sun, Oct 14, 2012 at 11:02 PM, seba.wagner@gmail.com <
seba.wagner@gmail.com> wrote:

> >But I would vote for not creating IPagableEntity.
> => Do you have an alternative name proposal?
>
> >Also we already has discussion regarding class renaming....
> >Are we still planning to do it?
> >Shall I handle it?*
> => If you refer to this ones:
> Users => User
> Adresses => Address
> States => State
> ... et cetera.
> It is still planned todo. But our code base is not stable enough currently.
> We have enough instability :)
> Renaming Entities will affect JPQL, a simple "eclipse refactoring" will not
> fix this at all.
> I would rather prefer to fix the Backup Export/Import, then create a
> "master backup file" that contains a lot of the eventualities and that we
> can use as reference for testing.
> After that we can refactor Entities and table names and do test it with our
> master backup file again.
>
> *do I need to take a look at your import/export issue or you going to
> fix it yourself?*
> => There are multiple issues here. Some queries don't work anymore because
> of refactoring with Lazy Loading and there is a general issue with the XML
> framework.
> I think I will have a look at this issue by the start of this week.
>
> We also still have some open issues for the Admin area like search fields,
> ordering of tables, creating/improving the CSS file for the layout of the
> forms and grids.
> And you are also already looking in howto bring WebSocket's and Atmosphere
> Framework into our stack.
> I think that is already a lot of stuff todo. We should complete components
> before we move on and add new things.
> Although I think your work regarding WebSockets/Tomcat7 and Atmosphere is
> really useful as those features will be the next big thing to integrate.
>
> What do you think?
>
> Sebastian
>
> 2012/10/14 Maxim Solodovnik <so...@gmail.com>
>
> > Also we already has discussion regarding class renaming....
> > Are we still planning to do it?
> > Shall I handle it?
> >
> > BTW do I need to take a look at your import/export issue or you going to
> > fix it yourself?
> > On Oct 14, 2012 10:05 PM, "Maxim Solodovnik" <so...@gmail.com>
> wrote:
> >
> > > I agree regarding interface and dao. But I would vote for not creating
> > > IPagableEntity. My idea was to create something like absttact
> > Identifiable,
> > > add id field to it and getter and setter. (All our entities has id)
> > > On Oct 14, 2012 7:14 PM, "seba.wagner@gmail.com" <
> seba.wagner@gmail.com>
> > > wrote:
> > >
> > >> Hi,
> > >>
> > >> I would like to propose the following naming conventions:
> > >>
> > >> Interfaces start with an "I"
> > >>
> > >> public interface IOmDao {
> > >> }
> > >>
> > >> Implementations like the DaoImpl (Data Access Object Implementation)
> > >> will be renamed to Dao (without the Impl, there is no need to write
> > "Impl"
> > >> if the Dao interface has the "I" in its name).
> > >>
> > >> So the UserDaoImpl will be simply:
> > >>  UserDao implements IOmDao
> > >>
> > >> And I would like to find a more meaningful name for "OmDao" and
> > >> "OmEntity"..
> > >> It might be better to name those interfaces by its usage, cause the
> name
> > >> "OpenMeetings" might change and it does not say so much about the
> usage
> > of
> > >> the interface.
> > >>
> > >> Maybe something like "IPagingDao" or "IPaginationDao"
> > >> and the corresponding "OmEntity" to "IPagingEntity".
> > >>
> > >> Sebastian
> > >>
> > >> --
> > >> Sebastian Wagner
> > >> https://twitter.com/#!/dead_lock
> > >> http://www.webbase-design.de
> > >> http://www.wagner-sebastian.com
> > >> seba.wagner@gmail.com
> > >>
> > >
> >
>
>
>
> --
> Sebastian Wagner
> https://twitter.com/#!/dead_lock
> http://www.webbase-design.de
> http://www.wagner-sebastian.com
> seba.wagner@gmail.com
>



-- 
WBR
Maxim aka solomax

Re: Naming convention for Interfaces and Dao's

Posted by "seba.wagner@gmail.com" <se...@gmail.com>.
>But I would vote for not creating IPagableEntity.
=> Do you have an alternative name proposal?

>Also we already has discussion regarding class renaming....
>Are we still planning to do it?
>Shall I handle it?*
=> If you refer to this ones:
Users => User
Adresses => Address
States => State
... et cetera.
It is still planned todo. But our code base is not stable enough currently.
We have enough instability :)
Renaming Entities will affect JPQL, a simple "eclipse refactoring" will not
fix this at all.
I would rather prefer to fix the Backup Export/Import, then create a
"master backup file" that contains a lot of the eventualities and that we
can use as reference for testing.
After that we can refactor Entities and table names and do test it with our
master backup file again.

*do I need to take a look at your import/export issue or you going to
fix it yourself?*
=> There are multiple issues here. Some queries don't work anymore because
of refactoring with Lazy Loading and there is a general issue with the XML
framework.
I think I will have a look at this issue by the start of this week.

We also still have some open issues for the Admin area like search fields,
ordering of tables, creating/improving the CSS file for the layout of the
forms and grids.
And you are also already looking in howto bring WebSocket's and Atmosphere
Framework into our stack.
I think that is already a lot of stuff todo. We should complete components
before we move on and add new things.
Although I think your work regarding WebSockets/Tomcat7 and Atmosphere is
really useful as those features will be the next big thing to integrate.

What do you think?

Sebastian

2012/10/14 Maxim Solodovnik <so...@gmail.com>

> Also we already has discussion regarding class renaming....
> Are we still planning to do it?
> Shall I handle it?
>
> BTW do I need to take a look at your import/export issue or you going to
> fix it yourself?
> On Oct 14, 2012 10:05 PM, "Maxim Solodovnik" <so...@gmail.com> wrote:
>
> > I agree regarding interface and dao. But I would vote for not creating
> > IPagableEntity. My idea was to create something like absttact
> Identifiable,
> > add id field to it and getter and setter. (All our entities has id)
> > On Oct 14, 2012 7:14 PM, "seba.wagner@gmail.com" <se...@gmail.com>
> > wrote:
> >
> >> Hi,
> >>
> >> I would like to propose the following naming conventions:
> >>
> >> Interfaces start with an "I"
> >>
> >> public interface IOmDao {
> >> }
> >>
> >> Implementations like the DaoImpl (Data Access Object Implementation)
> >> will be renamed to Dao (without the Impl, there is no need to write
> "Impl"
> >> if the Dao interface has the "I" in its name).
> >>
> >> So the UserDaoImpl will be simply:
> >>  UserDao implements IOmDao
> >>
> >> And I would like to find a more meaningful name for "OmDao" and
> >> "OmEntity"..
> >> It might be better to name those interfaces by its usage, cause the name
> >> "OpenMeetings" might change and it does not say so much about the usage
> of
> >> the interface.
> >>
> >> Maybe something like "IPagingDao" or "IPaginationDao"
> >> and the corresponding "OmEntity" to "IPagingEntity".
> >>
> >> Sebastian
> >>
> >> --
> >> Sebastian Wagner
> >> https://twitter.com/#!/dead_lock
> >> http://www.webbase-design.de
> >> http://www.wagner-sebastian.com
> >> seba.wagner@gmail.com
> >>
> >
>



-- 
Sebastian Wagner
https://twitter.com/#!/dead_lock
http://www.webbase-design.de
http://www.wagner-sebastian.com
seba.wagner@gmail.com

Re: Naming convention for Interfaces and Dao's

Posted by Maxim Solodovnik <so...@gmail.com>.
Also we already has discussion regarding class renaming....
Are we still planning to do it?
Shall I handle it?

BTW do I need to take a look at your import/export issue or you going to
fix it yourself?
On Oct 14, 2012 10:05 PM, "Maxim Solodovnik" <so...@gmail.com> wrote:

> I agree regarding interface and dao. But I would vote for not creating
> IPagableEntity. My idea was to create something like absttact Identifiable,
> add id field to it and getter and setter. (All our entities has id)
> On Oct 14, 2012 7:14 PM, "seba.wagner@gmail.com" <se...@gmail.com>
> wrote:
>
>> Hi,
>>
>> I would like to propose the following naming conventions:
>>
>> Interfaces start with an "I"
>>
>> public interface IOmDao {
>> }
>>
>> Implementations like the DaoImpl (Data Access Object Implementation)
>> will be renamed to Dao (without the Impl, there is no need to write "Impl"
>> if the Dao interface has the "I" in its name).
>>
>> So the UserDaoImpl will be simply:
>>  UserDao implements IOmDao
>>
>> And I would like to find a more meaningful name for "OmDao" and
>> "OmEntity"..
>> It might be better to name those interfaces by its usage, cause the name
>> "OpenMeetings" might change and it does not say so much about the usage of
>> the interface.
>>
>> Maybe something like "IPagingDao" or "IPaginationDao"
>> and the corresponding "OmEntity" to "IPagingEntity".
>>
>> Sebastian
>>
>> --
>> Sebastian Wagner
>> https://twitter.com/#!/dead_lock
>> http://www.webbase-design.de
>> http://www.wagner-sebastian.com
>> seba.wagner@gmail.com
>>
>

Re: Naming convention for Interfaces and Dao's

Posted by Maxim Solodovnik <so...@gmail.com>.
I agree regarding interface and dao. But I would vote for not creating
IPagableEntity. My idea was to create something like absttact Identifiable,
add id field to it and getter and setter. (All our entities has id)
On Oct 14, 2012 7:14 PM, "seba.wagner@gmail.com" <se...@gmail.com>
wrote:

> Hi,
>
> I would like to propose the following naming conventions:
>
> Interfaces start with an "I"
>
> public interface IOmDao {
> }
>
> Implementations like the DaoImpl (Data Access Object Implementation)
> will be renamed to Dao (without the Impl, there is no need to write "Impl"
> if the Dao interface has the "I" in its name).
>
> So the UserDaoImpl will be simply:
>  UserDao implements IOmDao
>
> And I would like to find a more meaningful name for "OmDao" and
> "OmEntity"..
> It might be better to name those interfaces by its usage, cause the name
> "OpenMeetings" might change and it does not say so much about the usage of
> the interface.
>
> Maybe something like "IPagingDao" or "IPaginationDao"
> and the corresponding "OmEntity" to "IPagingEntity".
>
> Sebastian
>
> --
> Sebastian Wagner
> https://twitter.com/#!/dead_lock
> http://www.webbase-design.de
> http://www.wagner-sebastian.com
> seba.wagner@gmail.com
>