You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@cassandra.apache.org by "Robert Coli (JIRA)" <ji...@apache.org> on 2010/03/10 08:57:27 UTC

[jira] Updated: (CASSANDRA-871) Two small cosmetic patches for inconsistent names in the JMX interface

     [ https://issues.apache.org/jira/browse/CASSANDRA-871?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Robert Coli updated CASSANDRA-871:
----------------------------------

    Attachment: getRangeToEndPointMap.To.getRangeToEndpointMap.patch
                GMFD.to.GOSSIP_STAGE.patch

> Two small cosmetic patches for inconsistent names in the JMX interface
> ----------------------------------------------------------------------
>
>                 Key: CASSANDRA-871
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-871
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Core
>            Reporter: Robert Coli
>            Priority: Minor
>         Attachments: getRangeToEndPointMap.To.getRangeToEndpointMap.patch, GMFD.to.GOSSIP_STAGE.patch
>
>
> Two small (cosmetic) changes (against 921220) to the names of things exposed via JMX :
> 1) GMFD.to.GOSSIP_STAGE.patch converts the name of the GOSSIP_STAGE JMXEnabledThreadPoolExecutor to "GOSSIP_STAGE" instead of the cryptic/legacy name "GMFD" in src/java/org/apache/cassandra/concurrent/StageManager.java.
> 2) getRangeToEndPointMap.To.getRangeToEndpointMap.patch changes all occurances of getRangeToEndPointMap to be "getRangeToEndpointMap" instead, in 5 different files. Practical result is that StorageService's MBean Operations no longer has both getRangeToEndPointMap (capital P Points) and getNaturalEndpoints (lower case p points).
> As a note, both "EndPoint" and "Endpoint" are used throughout the code currently. If folks feel there is any value to picking one ("Endpoint" per jbellis) and cosmetically patching to that standard, I am wlillng to do the work to generate the patches.. :)
> =Rob
> .

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.