You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@mesos.apache.org by "James Peach (JIRA)" <ji...@apache.org> on 2017/11/13 16:54:00 UTC

[jira] [Created] (MESOS-8215) Rename Queue::get to be more descriptive

James Peach created MESOS-8215:
----------------------------------

             Summary: Rename Queue::get to be more descriptive
                 Key: MESOS-8215
                 URL: https://issues.apache.org/jira/browse/MESOS-8215
             Project: Mesos
          Issue Type: Improvement
          Components: libprocess
            Reporter: James Peach


The {{Queue<T>::get}} member is quite misleadingly named. When you see {{foo.get()}}, this strongly suggests to the reader that `foo` is some sort of {{Option}}, since that is the most common pattern in {{libprocess}}.

We should call this operation {{pop}}, to indicate that is is a destructive retrieval of a the first queue element.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)