You are viewing a plain text version of this content. The canonical link for it is here.
Posted to jira@kafka.apache.org by "Ismael Juma (JIRA)" <ji...@apache.org> on 2018/01/01 10:22:00 UTC

[jira] [Resolved] (KAFKA-6307) mBeanName should be removed before returning from JmxReporter#removeAttribute()

     [ https://issues.apache.org/jira/browse/KAFKA-6307?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Ismael Juma resolved KAFKA-6307.
--------------------------------
       Resolution: Fixed
    Fix Version/s: 1.1.0

> mBeanName should be removed before returning from JmxReporter#removeAttribute()
> -------------------------------------------------------------------------------
>
>                 Key: KAFKA-6307
>                 URL: https://issues.apache.org/jira/browse/KAFKA-6307
>             Project: Kafka
>          Issue Type: Bug
>            Reporter: Ted Yu
>            Assignee: siva santhalingam
>             Fix For: 1.1.0
>
>
> JmxReporter$KafkaMbean showed up near the top in the first histo output from KAFKA-6199.
> In JmxReporter#removeAttribute() :
> {code}
>         KafkaMbean mbean = this.mbeans.get(mBeanName);
>         if (mbean != null)
>             mbean.removeAttribute(metricName.name());
>         return mbean;
> {code}
> mbeans.remove(mBeanName) should be called before returning.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)