You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@commons.apache.org by Stephen Colebourne <sc...@btopenworld.com> on 2003/12/11 21:04:40 UTC

Re: [lang] Mutables [was new StringBuffer.. what to call it]

MutableXxx is a group of classes which has been mooted on various
occaisions. It implies a simple holder onject for immutable values like int
and String. Last time I blocked it because I thought primitives was more
appropriate, but I've changed my mind and would now +1 a mutable subpackage
in [lang].

public class MutableString
  private String str;
  public String getString() {return str;}
  public void setString(String str) {this.str = str;}
}

Stephen

----- Original Message -----
From: "Ash .." <eq...@hotmail.com>
> >BTW: MutableString is a bad name as it can imply a class that holds a
> >String
> and has a getString and setString method.
>
> >Stephen
>
> Can you tell us why the name MutableString implies it has a getString and
> setString.
>
> And what do people think here of introducing a different term (say Strand)
> for this concept as I discussed earlier (I paste that here, last time it
was
> buried under confusion due to a typo.)
>
> "
> Talking about name, I would add my opinion that while it might be
> nice to have a name for the replacer that is much like the replacee,
> (StringBuf) one might prefer a more descriptive name at the expense
> of this convenience: (***  MutableString).
>
> As a compromise between the two, the name Strand can be adopted (Str...
> thus near the original one + can be defined to represent a mutable
> string contrasted with "String" which, by virtue of the so-named
> class in the API, is immutable.)
> "
>
> Ash
>
>
>
> ---------------------------------------------
>
> Run, rabbit run.
> Dig that hole, forget the sun,
> And when at last the work is done
> Don't sit down it's time to dig another one.
>
> _________________________________________________________________
> Our best dial-up offer is back.  Get MSN Dial-up Internet Service for 6
> months @ $9.95/month now! http://join.msn.com/?page=dept/dialup
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org