You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Eric Badger (JIRA)" <ji...@apache.org> on 2018/05/14 18:26:00 UTC

[jira] [Updated] (YARN-8284) get_docker_command refactoring

     [ https://issues.apache.org/jira/browse/YARN-8284?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Eric Badger updated YARN-8284:
------------------------------
    Attachment: YARN-8284.001.patch

> get_docker_command refactoring
> ------------------------------
>
>                 Key: YARN-8284
>                 URL: https://issues.apache.org/jira/browse/YARN-8284
>             Project: Hadoop YARN
>          Issue Type: Improvement
>    Affects Versions: 3.2.0, 3.1.1
>            Reporter: Jason Lowe
>            Assignee: Eric Badger
>            Priority: Minor
>         Attachments: YARN-8284.001.patch
>
>
> YARN-8274 occurred because get_docker_command's helper functions each have to remember to put the docker binary as the first argument.  This is error prone and causes code duplication for each of the helper functions.  It would be safer and simpler if get_docker_command initialized the docker binary argument in one place and each of the helper functions only added the arguments specific to their particular docker sub-command.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org