You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@shindig.apache.org by "tomer doron (JIRA)" <ji...@apache.org> on 2010/09/08 21:39:32 UTC

[jira] Created: (SHINDIG-1424) endless loop while encoding POJOs to JSON

endless loop while encoding POJOs to JSON
-----------------------------------------

                 Key: SHINDIG-1424
                 URL: https://issues.apache.org/jira/browse/SHINDIG-1424
             Project: Shindig
          Issue Type: Bug
          Components: Java
    Affects Versions: 2.0.0
            Reporter: tomer doron


my POJO includes a getter named "getSinglton" which return an instance of the same same class, due to the way org.apache.shindig.common.JsonUtil.getGetters is buit this is causing an endless loop when trying to serialize the POJO into JSON. unfortunately the "getSinglton" getter is required by another interface, thus,, i cannot simply rename it to overcome the naming convention issue. 

my proposed solution would be to introduce a way to hint JsonUtil.getGetters  to ignore the getter, perhaps a new annotation or a magic phrase in JsonProperty annotation.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (SHINDIG-1424) endless loop while encoding POJOs to JSON

Posted by "tomer doron (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/SHINDIG-1424?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

tomer doron updated SHINDIG-1424:
---------------------------------

    Description: 
my POJO includes a getter named "getSinglton" which return an instance of the same class, due to the way org.apache.shindig.common.JsonUtil.getGetters is buit this is causing an endless loop when trying to serialize the POJO into JSON. unfortunately the "getSinglton" getter is required by another interface, thus,, i cannot simply rename it to overcome the naming convention issue. 

my proposed solution would be to introduce a way to hint JsonUtil.getGetters  to ignore the getter, perhaps a new annotation or a magic phrase in JsonProperty annotation.

  was:
my POJO includes a getter named "getSinglton" which return an instance of the same same class, due to the way org.apache.shindig.common.JsonUtil.getGetters is buit this is causing an endless loop when trying to serialize the POJO into JSON. unfortunately the "getSinglton" getter is required by another interface, thus,, i cannot simply rename it to overcome the naming convention issue. 

my proposed solution would be to introduce a way to hint JsonUtil.getGetters  to ignore the getter, perhaps a new annotation or a magic phrase in JsonProperty annotation.


> endless loop while encoding POJOs to JSON
> -----------------------------------------
>
>                 Key: SHINDIG-1424
>                 URL: https://issues.apache.org/jira/browse/SHINDIG-1424
>             Project: Shindig
>          Issue Type: Bug
>          Components: Java
>    Affects Versions: 2.0.0
>            Reporter: tomer doron
>
> my POJO includes a getter named "getSinglton" which return an instance of the same class, due to the way org.apache.shindig.common.JsonUtil.getGetters is buit this is causing an endless loop when trying to serialize the POJO into JSON. unfortunately the "getSinglton" getter is required by another interface, thus,, i cannot simply rename it to overcome the naming convention issue. 
> my proposed solution would be to introduce a way to hint JsonUtil.getGetters  to ignore the getter, perhaps a new annotation or a magic phrase in JsonProperty annotation.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (SHINDIG-1424) endless loop while encoding POJOs to JSON

Posted by "tomer doron (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/SHINDIG-1424?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

tomer doron updated SHINDIG-1424:
---------------------------------

    Description: 
my POJO includes a getter named "getSingleton" which return an instance of the same class, due to the way org.apache.shindig.common.JsonUtil.getGetters is buit this is causing an endless loop when trying to serialize the POJO into JSON. unfortunately the "getSingleton" getter is required by another interface, thus, i cannot simply rename it to overcome the naming convention issue. 

my proposed solution would be to introduce a way to hint JsonUtil.getGetters  to ignore the getter, perhaps a new annotation or a magic phrase in JsonProperty annotation.

  was:
my POJO includes a getter named "getSingleton" which return an instance of the same class, due to the way org.apache.shindig.common.JsonUtil.getGetters is buit this is causing an endless loop when trying to serialize the POJO into JSON. unfortunately the "getSingleton" getter is required by another interface, thus,, i cannot simply rename it to overcome the naming convention issue. 

my proposed solution would be to introduce a way to hint JsonUtil.getGetters  to ignore the getter, perhaps a new annotation or a magic phrase in JsonProperty annotation.


> endless loop while encoding POJOs to JSON
> -----------------------------------------
>
>                 Key: SHINDIG-1424
>                 URL: https://issues.apache.org/jira/browse/SHINDIG-1424
>             Project: Shindig
>          Issue Type: Bug
>          Components: Java
>    Affects Versions: 2.0.0
>            Reporter: tomer doron
>
> my POJO includes a getter named "getSingleton" which return an instance of the same class, due to the way org.apache.shindig.common.JsonUtil.getGetters is buit this is causing an endless loop when trying to serialize the POJO into JSON. unfortunately the "getSingleton" getter is required by another interface, thus, i cannot simply rename it to overcome the naming convention issue. 
> my proposed solution would be to introduce a way to hint JsonUtil.getGetters  to ignore the getter, perhaps a new annotation or a magic phrase in JsonProperty annotation.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (SHINDIG-1424) endless loop while encoding POJOs to JSON

Posted by "tomer doron (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/SHINDIG-1424?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

tomer doron updated SHINDIG-1424:
---------------------------------

    Description: 
my POJO includes a getter named "getSingleton" which return an instance of the same class, due to the way org.apache.shindig.common.JsonUtil.getGetters is buit this is causing an endless loop when trying to serialize the POJO into JSON. unfortunately the "getSingleton" getter is required by another interface, thus,, i cannot simply rename it to overcome the naming convention issue. 

my proposed solution would be to introduce a way to hint JsonUtil.getGetters  to ignore the getter, perhaps a new annotation or a magic phrase in JsonProperty annotation.

  was:
my POJO includes a getter named "getSinglton" which return an instance of the same class, due to the way org.apache.shindig.common.JsonUtil.getGetters is buit this is causing an endless loop when trying to serialize the POJO into JSON. unfortunately the "getSinglton" getter is required by another interface, thus,, i cannot simply rename it to overcome the naming convention issue. 

my proposed solution would be to introduce a way to hint JsonUtil.getGetters  to ignore the getter, perhaps a new annotation or a magic phrase in JsonProperty annotation.


> endless loop while encoding POJOs to JSON
> -----------------------------------------
>
>                 Key: SHINDIG-1424
>                 URL: https://issues.apache.org/jira/browse/SHINDIG-1424
>             Project: Shindig
>          Issue Type: Bug
>          Components: Java
>    Affects Versions: 2.0.0
>            Reporter: tomer doron
>
> my POJO includes a getter named "getSingleton" which return an instance of the same class, due to the way org.apache.shindig.common.JsonUtil.getGetters is buit this is causing an endless loop when trying to serialize the POJO into JSON. unfortunately the "getSingleton" getter is required by another interface, thus,, i cannot simply rename it to overcome the naming convention issue. 
> my proposed solution would be to introduce a way to hint JsonUtil.getGetters  to ignore the getter, perhaps a new annotation or a magic phrase in JsonProperty annotation.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.