You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "Xiaobing Zhou (JIRA)" <ji...@apache.org> on 2017/03/02 01:56:45 UTC

[jira] [Comment Edited] (HBASE-17465) [C++] implement request retry mechanism over RPC

    [ https://issues.apache.org/jira/browse/HBASE-17465?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15891461#comment-15891461 ] 

Xiaobing Zhou edited comment on HBASE-17465 at 3/2/17 1:56 AM:
---------------------------------------------------------------

posted v9
# fixed broken promise
# removed AsyncConnection
# rename ElapsedMs() to ElapsedMillis()
# changed ./hbase-protocol/src/main/protobuf/Client.proto
# removed client-test.h



was (Author: xiaobingo):
posted v9
#fixed broken promise
#removed AsyncConnection
#rename ElapsedMs() to ElapsedMillis()
#changed ./hbase-protocol/src/main/protobuf/Client.proto
#removed client-test.h


> [C++] implement request retry mechanism over RPC
> ------------------------------------------------
>
>                 Key: HBASE-17465
>                 URL: https://issues.apache.org/jira/browse/HBASE-17465
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Xiaobing Zhou
>            Assignee: Xiaobing Zhou
>         Attachments: HBASE-17465-HBASE-14850.000.patch, HBASE-17465-HBASE-14850.001.patch, HBASE-17465-HBASE-14850.002.patch, HBASE-17465-HBASE-14850.003.patch, HBASE-17465-HBASE-14850.004.patch, HBASE-17465-HBASE-14850.005.patch, HBASE-17465-HBASE-14850.006.patch, HBASE-17465-HBASE-14850.007.patch, HBASE-17465-HBASE-14850.008.patch, HBASE-17465-HBASE-14850.009.patch
>
>
> HBASE-17051 implemented RPC layer. Requests retries will make system reliable. This JIRA proposes adding it, which corresponds to similar implementation in  SingleRequestCallerBuilder (or BatchCallerBuilder, ScanSingleRegionCallerBuilder, SmallScanCallerBuilder, etc.) and AsyncSingleRequestRpcRetryingCaller. As a bonus, retry should be more generic, decoupled with HRegionLocation.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)