You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@cassandra.apache.org by "Benedict (Jira)" <ji...@apache.org> on 2019/08/20 15:17:00 UTC
[jira] [Commented] (CASSANDRA-15285) Rename StatsMetadata
estimatedColumnCount to estimatedCellPerPartitionCount
[ https://issues.apache.org/jira/browse/CASSANDRA-15285?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16911450#comment-16911450 ]
Benedict commented on CASSANDRA-15285:
--------------------------------------
Thanks. I've pushed [here|https://github.com/belliottsmith/cassandra/tree/15285] a branch with the mentioned method, and also {{ColumnFamilyStore.getMeanColumns}} renamed.
There's also a reasonable question around if we should rename {{TableMetrics.estimatedColumnCountHistogram}}, but given this has compatibility implications (with its JMX name) I think it's OK to leave it.
If you want to +1 the follow-up, I'll commit to trunk.
> Rename StatsMetadata estimatedColumnCount to estimatedCellPerPartitionCount
> ---------------------------------------------------------------------------
>
> Key: CASSANDRA-15285
> URL: https://issues.apache.org/jira/browse/CASSANDRA-15285
> Project: Cassandra
> Issue Type: Task
> Components: Local/SSTable
> Reporter: Jordan West
> Assignee: Jordan West
> Priority: Normal
> Fix For: 4.x
>
>
> This renaming was done previously in MetadataCollector but not in StatsMetadata. The proposed name is more descriptive of what the field now represents.
--
This message was sent by Atlassian Jira
(v8.3.2#803003)
---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@cassandra.apache.org
For additional commands, e-mail: commits-help@cassandra.apache.org