You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ignite.apache.org by "Mikhail Efremov (Jira)" <ji...@apache.org> on 2025/03/10 14:55:00 UTC
[jira] [Assigned] (IGNITE-24749) Remove some system configuration properties duplicity and add
[ https://issues.apache.org/jira/browse/IGNITE-24749?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Mikhail Efremov reassigned IGNITE-24749:
----------------------------------------
Assignee: Mikhail Efremov
> Remove some system configuration properties duplicity and add
> --------------------------------------------------------------
>
> Key: IGNITE-24749
> URL: https://issues.apache.org/jira/browse/IGNITE-24749
> Project: Ignite
> Issue Type: Improvement
> Reporter: Mikhail Efremov
> Assignee: Mikhail Efremov
> Priority: Major
> Labels: ignite-3
>
> *Description*
> During IGNITE-24570 there were found several properties that are duplicated in tests:
> * {{INTERVAL_SYSTEM_PROPERTY_NAME = "metastorageCompactionInterval"}}
> * {{DATA_AVAILABILITY_TIME_SYSTEM_PROPERTY_NAME = "metastorageCompactionDataAvailabilityTime"}}
> In tests there should be imports instead of duplicity. Moreover for all found properties form IGNITE-24570 there should be a test that checks that properties names weren't changed.
> *Motivation*
> We shouldn't duplicate code without a reason, compatibility may be checked through tests.
> *Definition of Done*
> * {{INTERVAL_SYSTEM_PROPERTY_NAME}} field is removed from {{MetaStorageCompactionTriggerConfigurationTest}}.
> * field is removed from {{MetaStorageCompactionTriggerConfigurationTest}}.
> * Compatibility tests for the follow properties are implemented:
> ** {{REBALANCE_RETRY_DELAY_DEFAULT}}
> ** {{PARTITION_DISTRIBUTION_RESET_TIMEOUT_DEFAULT_VALUE}}
> ** {{INTERVAL_SYSTEM_PROPERTY_NAME}}
> ** {{DATA_AVAILABILITY_TIME_SYSTEM_PROPERTY_NAME}}
> ** {{LOCK_MAP_SIZE_PROPERTY_NAME}}
--
This message was sent by Atlassian Jira
(v8.20.10#820010)