You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@lucy.apache.org by "Marvin Humphrey (JIRA)" <ji...@apache.org> on 2011/03/11 20:17:59 UTC

[lucy-issues] [jira] Created: (LUCY-132) Move Tokenizer, Stemmer, Stopalizer

Move Tokenizer, Stemmer, Stopalizer
-----------------------------------

                 Key: LUCY-132
                 URL: https://issues.apache.org/jira/browse/LUCY-132
             Project: Lucy
          Issue Type: Improvement
          Components: Analysis
    Affects Versions: 0.1-incubating
            Reporter: Marvin Humphrey
            Priority: Minor
             Fix For: 0.1-incubating


In anticipation of creating interfaces using generic names such as
"Tokenizer", "Stemmer", and "StopFilter", we should vacate those class names
and give the current implementations more specific names:

{noformat}
    Lucy::Analysis::Tokenizer  => Lucy::Analysis::RegexTokenizer
    Lucy::Analysis::Stemmer    => Lucy::Analysis::SnowballStemmer
    Lucy::Analysis::Stopalizer => Lucy::Analysis::SnowballStopFilter
{noformat}

Discussion: <http://s.apache.org/RbX>, <http://s.apache.org/WVJ>.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

[lucy-issues] [jira] Updated: (LUCY-132) Move Tokenizer, Stemmer, Stopalizer

Posted by "Marvin Humphrey (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/LUCY-132?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Marvin Humphrey updated LUCY-132:
---------------------------------

    Attachment: regex_tokenizer.patch

The attached regex_tokenizer.patch file must be applied after performing a
similar set of "svn move" commands.

> Move Tokenizer, Stemmer, Stopalizer
> -----------------------------------
>
>                 Key: LUCY-132
>                 URL: https://issues.apache.org/jira/browse/LUCY-132
>             Project: Lucy
>          Issue Type: Improvement
>          Components: Analysis
>    Affects Versions: 0.1-incubating
>            Reporter: Marvin Humphrey
>            Priority: Minor
>             Fix For: 0.1-incubating
>
>         Attachments: regex_tokenizer.patch, snowball_stemmer.patch, snowball_stopfilter.patch
>
>
> In anticipation of creating interfaces using generic names such as
> "Tokenizer", "Stemmer", and "StopFilter", we should vacate those class names
> and give the current implementations more specific names:
> {noformat}
>     Lucy::Analysis::Tokenizer  => Lucy::Analysis::RegexTokenizer
>     Lucy::Analysis::Stemmer    => Lucy::Analysis::SnowballStemmer
>     Lucy::Analysis::Stopalizer => Lucy::Analysis::SnowballStopFilter
> {noformat}
> Discussion: <http://s.apache.org/RbX>, <http://s.apache.org/WVJ>.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

[lucy-issues] [jira] Resolved: (LUCY-132) Move Tokenizer, Stemmer, Stopalizer

Posted by "Marvin Humphrey (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/LUCY-132?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Marvin Humphrey resolved LUCY-132.
----------------------------------

    Resolution: Fixed
      Assignee: Marvin Humphrey

Committed as r1080735, r1080766, and r1080795.

> Move Tokenizer, Stemmer, Stopalizer
> -----------------------------------
>
>                 Key: LUCY-132
>                 URL: https://issues.apache.org/jira/browse/LUCY-132
>             Project: Lucy
>          Issue Type: Improvement
>          Components: Analysis
>    Affects Versions: 0.1-incubating
>            Reporter: Marvin Humphrey
>            Assignee: Marvin Humphrey
>            Priority: Minor
>             Fix For: 0.1-incubating
>
>         Attachments: regex_tokenizer.patch, snowball_stemmer.patch, snowball_stopfilter.patch
>
>
> In anticipation of creating interfaces using generic names such as
> "Tokenizer", "Stemmer", and "StopFilter", we should vacate those class names
> and give the current implementations more specific names:
> {noformat}
>     Lucy::Analysis::Tokenizer  => Lucy::Analysis::RegexTokenizer
>     Lucy::Analysis::Stemmer    => Lucy::Analysis::SnowballStemmer
>     Lucy::Analysis::Stopalizer => Lucy::Analysis::SnowballStopFilter
> {noformat}
> Discussion: <http://s.apache.org/RbX>, <http://s.apache.org/WVJ>.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

[lucy-issues] [jira] Updated: (LUCY-132) Move Tokenizer, Stemmer, Stopalizer

Posted by "Marvin Humphrey (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/LUCY-132?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Marvin Humphrey updated LUCY-132:
---------------------------------

    Attachment: snowball_stemmer.patch

The attached snowball_stemmer.patch must be applied after running the
following "svn move" commands:

{noformat}
svn move core/Lucy/Analysis/Stemmer.c core/Lucy/Analysis/SnowballStemmer.c
svn move core/Lucy/Analysis/Stemmer.cfh core/Lucy/Analysis/SnowballStemmer.cfh
svn move core/Lucy/Test/Analysis/TestStemmer.c core/Lucy/Test/Analysis/TestSnowballStemmer.c
svn move core/Lucy/Test/Analysis/TestStemmer.cfh core/Lucy/Test/Analysis/TestSnowballStemmer.cfh
svn move perl/lib/Lucy/Analysis/Stemmer.pm perl/lib/Lucy/Analysis/SnowballStemmer.pm
svn move perl/t/156-stemmer.t perl/t/156-snowball_stemmer.t
svn move perl/t/core/156-stemmer.t perl/t/core/156-snowball_stemmer.t
{noformat}


> Move Tokenizer, Stemmer, Stopalizer
> -----------------------------------
>
>                 Key: LUCY-132
>                 URL: https://issues.apache.org/jira/browse/LUCY-132
>             Project: Lucy
>          Issue Type: Improvement
>          Components: Analysis
>    Affects Versions: 0.1-incubating
>            Reporter: Marvin Humphrey
>            Priority: Minor
>             Fix For: 0.1-incubating
>
>         Attachments: snowball_stemmer.patch
>
>
> In anticipation of creating interfaces using generic names such as
> "Tokenizer", "Stemmer", and "StopFilter", we should vacate those class names
> and give the current implementations more specific names:
> {noformat}
>     Lucy::Analysis::Tokenizer  => Lucy::Analysis::RegexTokenizer
>     Lucy::Analysis::Stemmer    => Lucy::Analysis::SnowballStemmer
>     Lucy::Analysis::Stopalizer => Lucy::Analysis::SnowballStopFilter
> {noformat}
> Discussion: <http://s.apache.org/RbX>, <http://s.apache.org/WVJ>.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

[lucy-issues] [jira] Updated: (LUCY-132) Move Tokenizer, Stemmer, Stopalizer

Posted by "Marvin Humphrey (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/LUCY-132?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Marvin Humphrey updated LUCY-132:
---------------------------------

    Attachment: snowball_stopfilter.patch

The attached snowball_stopfilter.patch must be applied after a similar set of
"svn move" commands.

> Move Tokenizer, Stemmer, Stopalizer
> -----------------------------------
>
>                 Key: LUCY-132
>                 URL: https://issues.apache.org/jira/browse/LUCY-132
>             Project: Lucy
>          Issue Type: Improvement
>          Components: Analysis
>    Affects Versions: 0.1-incubating
>            Reporter: Marvin Humphrey
>            Priority: Minor
>             Fix For: 0.1-incubating
>
>         Attachments: snowball_stemmer.patch, snowball_stopfilter.patch
>
>
> In anticipation of creating interfaces using generic names such as
> "Tokenizer", "Stemmer", and "StopFilter", we should vacate those class names
> and give the current implementations more specific names:
> {noformat}
>     Lucy::Analysis::Tokenizer  => Lucy::Analysis::RegexTokenizer
>     Lucy::Analysis::Stemmer    => Lucy::Analysis::SnowballStemmer
>     Lucy::Analysis::Stopalizer => Lucy::Analysis::SnowballStopFilter
> {noformat}
> Discussion: <http://s.apache.org/RbX>, <http://s.apache.org/WVJ>.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira