You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@airflow.apache.org by "diederikvdv (via GitHub)" <gi...@apache.org> on 2024/10/31 17:15:31 UTC
Re: [I] Error migrating database to Airflow version 2.9.3 [airflow]
diederikvdv commented on issue #40928:
URL: https://github.com/apache/airflow/issues/40928#issuecomment-2450410728
Same issue here. Tried with mysql:8.0.34 and with mysql:8.0.40
pymysql: version = "1.1.1"
sqlalchemy: version = "1.4.52"
We are already running Airflow for a while at 2.9.0, but upgrading results in the above error.
What would be the best migration step to upgrade? @ephraimbuddy
Reproduce:
On our development copy I created a new database with Airflow version 2.10.2. This works as expected
Downgrading from 2.10.2 to 2.7.0 succeeds (or any other version below 2.9.3)
upgrading to 2.10.2 fails
```
airflow db downgrade --to-version=2.7.0
airflow db upgrade --to-version=2.10.2
```
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: commits-unsubscribe@airflow.apache.org
For queries about this service, please contact Infrastructure at:
users@infra.apache.org