You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hc.apache.org by Roland Weber <ht...@dubioso.net> on 2007/02/21 19:08:49 UTC

Re: svn commit: r510119 - in /jakarta/httpcomponents/httpcore/trunk: module-main/src/main/java/org/apache/http/ module-main/src/main/java/org/apache/http/impl/ module-main/src/test/java/org/apache/http/impl/ module-main/src/test/java/org/apache/http/mockup...

Hi Oleg,

> HTTPCORE-42: 
> 
> * Moved socket timeout methods to the HttpConnection interface

I was quite satisfied that our generic connection interfaces had
nothing to do with sockets. As is it just in the method names and
does not actually reference the Socket class I'm still OK with this
change. Just wanted to put it on record.

cheers,
  Roland

> +++ jakarta/httpcomponents/httpcore/trunk/module-main/src/main/java/org/apache/http/HttpConnection.java Wed Feb 21 09:52:36 2007
> @@ -77,6 +77,22 @@
> +    void setSocketTimeout(int timeout);
> +    int getSocketTimeout();


---------------------------------------------------------------------
To unsubscribe, e-mail: httpcomponents-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpcomponents-dev-help@jakarta.apache.org


Re: [HttpCore] Home for socket timeout; was Re: svn commit: r510119

Posted by Roland Weber <ht...@dubioso.net>.
Hi Oleg,

> Will renaming xxxSocketTimeout to xxxIOTimeout be an improvement? One
> way or another we need a generic means of handling connection I/O
> timeouts for the client side of the 'expect: continue' handshake.

Let's leave it as it is. Otherwise we'll just have to point more
users to those methods. With setSocketTimeout as the name, they'll
find it themselves.

cheers,
  Roland


---------------------------------------------------------------------
To unsubscribe, e-mail: httpcomponents-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpcomponents-dev-help@jakarta.apache.org


[HttpCore] Home for socket timeout; was Re: svn commit: r510119

Posted by Oleg Kalnichevski <ol...@apache.org>.
On Wed, 2007-02-21 at 19:08 +0100, Roland Weber wrote:
> Hi Oleg,
> 
> > HTTPCORE-42: 
> > 
> > * Moved socket timeout methods to the HttpConnection interface
> 
> I was quite satisfied that our generic connection interfaces had
> nothing to do with sockets. As is it just in the method names and
> does not actually reference the Socket class I'm still OK with this
> change. Just wanted to put it on record.
> 
> cheers,
>   Roland
> 

Hi Roland

Will renaming xxxSocketTimeout to xxxIOTimeout be an improvement? One
way or another we need a generic means of handling connection I/O
timeouts for the client side of the 'expect: continue' handshake.

Oleg

> > +++ jakarta/httpcomponents/httpcore/trunk/module-main/src/main/java/org/apache/http/HttpConnection.java Wed Feb 21 09:52:36 2007
> > @@ -77,6 +77,22 @@
> > +    void setSocketTimeout(int timeout);
> > +    int getSocketTimeout();
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: httpcomponents-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: httpcomponents-dev-help@jakarta.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: httpcomponents-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpcomponents-dev-help@jakarta.apache.org