You are viewing a plain text version of this content. The canonical link for it is here.
Posted to mapreduce-issues@hadoop.apache.org by "Josh Wills (JIRA)" <ji...@apache.org> on 2011/06/30 19:14:28 UTC

[jira] [Created] (MAPREDUCE-2633) MR-279: Add a getCounter(Enum) method to the Counters interface

MR-279: Add a getCounter(Enum) method to the Counters interface
---------------------------------------------------------------

                 Key: MAPREDUCE-2633
                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-2633
             Project: Hadoop Map/Reduce
          Issue Type: Improvement
          Components: mrv2
         Environment: All
            Reporter: Josh Wills
            Priority: Minor


I'm fixing a few TODOs I came across in TaskAttemptImpl.java related to the fact that the MRv2 Counters interface don't expose a getCounter(Enum) method for accessing a Counter using the enum's class as the group name and the enum's value as the name of the counter.

Will add the patch momentarily.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (MAPREDUCE-2633) MR-279: Add a getCounter(Enum) method to the Counters interface

Posted by "Sharad Agarwal (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/MAPREDUCE-2633?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13061055#comment-13061055 ] 

Sharad Agarwal commented on MAPREDUCE-2633:
-------------------------------------------

currently org/apache/hadoop/mapreduce/v2/api/records/Counters.java is used only internally. its ok go with Enum.

+1

> MR-279: Add a getCounter(Enum) method to the Counters interface
> ---------------------------------------------------------------
>
>                 Key: MAPREDUCE-2633
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-2633
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>          Components: mrv2
>         Environment: All
>            Reporter: Josh Wills
>            Assignee: Josh Wills
>            Priority: Minor
>         Attachments: MAPREDUCE-2633.patch
>
>
> I'm fixing a few TODOs I came across in TaskAttemptImpl.java related to the fact that the MRv2 Counters interface don't expose a getCounter(Enum) method for accessing a Counter using the enum's class as the group name and the enum's value as the name of the counter.
> Will add the patch momentarily.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (MAPREDUCE-2633) MR-279: Add a getCounter(Enum) method to the Counters interface

Posted by "Arun C Murthy (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/MAPREDUCE-2633?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13059263#comment-13059263 ] 

Arun C Murthy commented on MAPREDUCE-2633:
------------------------------------------

The patch looks fine, thanks Josh!

Sharad could you please take a quick look too?

One thing - there was some talk of deprecating Counters.getCounter(Enum) in favour of Counters.getCounter(String). I need to refresh my memory, in which case we might deprecate the one added by Josh right-away. Thoughts?

> MR-279: Add a getCounter(Enum) method to the Counters interface
> ---------------------------------------------------------------
>
>                 Key: MAPREDUCE-2633
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-2633
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>          Components: mrv2
>         Environment: All
>            Reporter: Josh Wills
>            Assignee: Josh Wills
>            Priority: Minor
>         Attachments: MAPREDUCE-2633.patch
>
>
> I'm fixing a few TODOs I came across in TaskAttemptImpl.java related to the fact that the MRv2 Counters interface don't expose a getCounter(Enum) method for accessing a Counter using the enum's class as the group name and the enum's value as the name of the counter.
> Will add the patch momentarily.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (MAPREDUCE-2633) MR-279: Add a getCounter(Enum) method to the Counters interface

Posted by "Josh Wills (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/MAPREDUCE-2633?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Josh Wills updated MAPREDUCE-2633:
----------------------------------

    Attachment: MAPREDUCE-2633.patch

> MR-279: Add a getCounter(Enum) method to the Counters interface
> ---------------------------------------------------------------
>
>                 Key: MAPREDUCE-2633
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-2633
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>          Components: mrv2
>         Environment: All
>            Reporter: Josh Wills
>            Priority: Minor
>         Attachments: MAPREDUCE-2633.patch
>
>
> I'm fixing a few TODOs I came across in TaskAttemptImpl.java related to the fact that the MRv2 Counters interface don't expose a getCounter(Enum) method for accessing a Counter using the enum's class as the group name and the enum's value as the name of the counter.
> Will add the patch momentarily.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (MAPREDUCE-2633) MR-279: Add a getCounter(Enum) method to the Counters interface

Posted by "Josh Wills (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/MAPREDUCE-2633?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13059287#comment-13059287 ] 

Josh Wills commented on MAPREDUCE-2633:
---------------------------------------

Thanks Arun-- re: Counters.getCounter(String), I'd be happy to implement the API that way- what are the semantics of the String?

> MR-279: Add a getCounter(Enum) method to the Counters interface
> ---------------------------------------------------------------
>
>                 Key: MAPREDUCE-2633
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-2633
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>          Components: mrv2
>         Environment: All
>            Reporter: Josh Wills
>            Assignee: Josh Wills
>            Priority: Minor
>         Attachments: MAPREDUCE-2633.patch
>
>
> I'm fixing a few TODOs I came across in TaskAttemptImpl.java related to the fact that the MRv2 Counters interface don't expose a getCounter(Enum) method for accessing a Counter using the enum's class as the group name and the enum's value as the name of the counter.
> Will add the patch momentarily.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Resolved] (MAPREDUCE-2633) MR-279: Add a getCounter(Enum) method to the Counters interface

Posted by "Sharad Agarwal (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/MAPREDUCE-2633?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Sharad Agarwal resolved MAPREDUCE-2633.
---------------------------------------

      Resolution: Fixed
    Hadoop Flags: [Reviewed]

I just committed this. Thanks Josh!

> MR-279: Add a getCounter(Enum) method to the Counters interface
> ---------------------------------------------------------------
>
>                 Key: MAPREDUCE-2633
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-2633
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>          Components: mrv2
>         Environment: All
>            Reporter: Josh Wills
>            Assignee: Josh Wills
>            Priority: Minor
>         Attachments: MAPREDUCE-2633.patch
>
>
> I'm fixing a few TODOs I came across in TaskAttemptImpl.java related to the fact that the MRv2 Counters interface don't expose a getCounter(Enum) method for accessing a Counter using the enum's class as the group name and the enum's value as the name of the counter.
> Will add the patch momentarily.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Assigned] (MAPREDUCE-2633) MR-279: Add a getCounter(Enum) method to the Counters interface

Posted by "Arun C Murthy (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/MAPREDUCE-2633?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Arun C Murthy reassigned MAPREDUCE-2633:
----------------------------------------

    Assignee: Josh Wills

> MR-279: Add a getCounter(Enum) method to the Counters interface
> ---------------------------------------------------------------
>
>                 Key: MAPREDUCE-2633
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-2633
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>          Components: mrv2
>         Environment: All
>            Reporter: Josh Wills
>            Assignee: Josh Wills
>            Priority: Minor
>         Attachments: MAPREDUCE-2633.patch
>
>
> I'm fixing a few TODOs I came across in TaskAttemptImpl.java related to the fact that the MRv2 Counters interface don't expose a getCounter(Enum) method for accessing a Counter using the enum's class as the group name and the enum's value as the name of the counter.
> Will add the patch momentarily.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira