You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@iotdb.apache.org by "XiangweiWei (Jira)" <ji...@apache.org> on 2021/01/28 02:28:00 UTC
[jira] [Commented] (IOTDB-1085) Refactoring "transformQuery" method
[ https://issues.apache.org/jira/browse/IOTDB-1085?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17273261#comment-17273261 ]
XiangweiWei commented on IOTDB-1085:
------------------------------------
It has been in progress now actually. Thanks for your suggestion.
> Refactoring "transformQuery" method
> -----------------------------------
>
> Key: IOTDB-1085
> URL: https://issues.apache.org/jira/browse/IOTDB-1085
> Project: Apache IoTDB
> Issue Type: Improvement
> Components: Others
> Reporter: weizihan
> Assignee: XiangweiWei
> Priority: Critical
> Attachments: image-2020-12-28-14-11-22-516.png, image-2020-12-28-14-21-36-561.png, image-2020-12-28-14-22-04-775.png, image-2020-12-28-14-22-35-650.png
>
>
> Currently, the method of org.apache.iotdb.db.qp.strategy.PhysicalGenerator#transformQuery has reached about 300 line, and there are lots of "if else" in this method. In order to easily maintain it, it should be refactored into more readable one, I think.
>
> Related pic:
> !image-2020-12-28-14-11-22-516.png|width=518,height=60!
> !image-2020-12-28-14-21-36-561.png|width=553,height=710!
> !image-2020-12-28-14-22-04-775.png|width=539,height=670!
>
> !image-2020-12-28-14-22-35-650.png|width=571,height=761!
>
--
This message was sent by Atlassian Jira
(v8.3.4#803005)