You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@mesos.apache.org by "Dominic Hamon (JIRA)" <ji...@apache.org> on 2014/07/01 17:52:24 UTC

[jira] [Commented] (MESOS-1550) MesosSchedulerDriver should never, ever, call 'stop'.

    [ https://issues.apache.org/jira/browse/MESOS-1550?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14048983#comment-14048983 ] 

Dominic Hamon commented on MESOS-1550:
--------------------------------------

[~wfarner] Separating out the two modes of {{stop()}} into two methods instead of relying on the boolean parameter probably makes a great deal of sense. Taking the opportunity to rename it to be clearer might also help.

I believe this issue will naturally be deprecated once a low-level API as per MESOS-1127 is available, though I should let [~benjaminhindman] speak to that.

> MesosSchedulerDriver should never, ever, call 'stop'.
> -----------------------------------------------------
>
>                 Key: MESOS-1550
>                 URL: https://issues.apache.org/jira/browse/MESOS-1550
>             Project: Mesos
>          Issue Type: Bug
>          Components: framework, java api, python api
>    Affects Versions: 0.14.0, 0.14.1, 0.14.2, 0.17.0, 0.16.0, 0.15.0, 0.18.0, 0.19.0
>            Reporter: Benjamin Hindman
>            Assignee: Benjamin Hindman
>            Priority: Critical
>             Fix For: 0.20.0
>
>
> Using MesosSchedulerDriver.stop causes the master to unregister the framework. The library should never make this decision for a framework, it should defer to the framework itself.



--
This message was sent by Atlassian JIRA
(v6.2#6252)