You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@commons.apache.org by "Claudio Squarcella (Created) (JIRA)" <ji...@apache.org> on 2012/02/19 13:36:34 UTC
[jira] [Created] (SANDBOX-395) Correct names for classes and
variables related to operations on weights
Correct names for classes and variables related to operations on weights
------------------------------------------------------------------------
Key: SANDBOX-395
URL: https://issues.apache.org/jira/browse/SANDBOX-395
Project: Commons Sandbox
Issue Type: Improvement
Components: Graph
Reporter: Claudio Squarcella
Assignee: Claudio Squarcella
Priority: Minor
Hi all,
as discussed in ML already the current classes/variables that refer to operations on weights can be renamed for better expressiveness:
* all the classes under {{weight.primitive}} should be renamed from {{XXX}} to {{XXXOperations}} because they actually contain operations on weights (they do not represent weights themselves);
* in the actual algorithms, all variable names for weight operations should actually be something like {{weightOperations}} instead of the name of the interface (e.g. {{orderedMonoid}}).
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] [Commented] (SANDBOX-395) Correct names for classes and
variables related to operations on weights
Posted by "Simone Tripodi (Commented) (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/SANDBOX-395?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13212973#comment-13212973 ]
Simone Tripodi commented on SANDBOX-395:
----------------------------------------
Hi Claudio,
please commit it! eventual modifications can be performed while working, I'm confident you know very well the topic ;)
Best,
-Simo
> Correct names for classes and variables related to operations on weights
> ------------------------------------------------------------------------
>
> Key: SANDBOX-395
> URL: https://issues.apache.org/jira/browse/SANDBOX-395
> Project: Commons Sandbox
> Issue Type: Improvement
> Components: Graph
> Reporter: Claudio Squarcella
> Assignee: Claudio Squarcella
> Priority: Minor
> Labels: graph, operations, weight
> Attachments: SANDBOX-395_CorrectClassAndVariableNamesForWeightOperations.patch
>
>
> Hi all,
> as discussed in ML already the current classes/variables that refer to operations on weights can be renamed for better expressiveness:
> * all the classes under {{weight.primitive}} should be renamed from {{XXX}} to {{XXXOperations}} because they actually contain operations on weights (they do not represent weights themselves);
> * in the actual algorithms, all variable names for weight operations should actually be something like {{weightOperations}} instead of the name of the interface (e.g. {{orderedMonoid}}).
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] [Resolved] (SANDBOX-395) Correct names for classes and
variables related to operations on weights
Posted by "Claudio Squarcella (Resolved) (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/SANDBOX-395?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Claudio Squarcella resolved SANDBOX-395.
----------------------------------------
Resolution: Fixed
fixed, see [revision 1292272|http://svn.apache.org/viewvc?view=revision&revision=1292272].
> Correct names for classes and variables related to operations on weights
> ------------------------------------------------------------------------
>
> Key: SANDBOX-395
> URL: https://issues.apache.org/jira/browse/SANDBOX-395
> Project: Commons Sandbox
> Issue Type: Improvement
> Components: Graph
> Reporter: Claudio Squarcella
> Assignee: Claudio Squarcella
> Priority: Minor
> Labels: graph, operations, weight
> Attachments: SANDBOX-395_CorrectClassAndVariableNamesForWeightOperations.patch
>
>
> Hi all,
> as discussed in ML already the current classes/variables that refer to operations on weights can be renamed for better expressiveness:
> * all the classes under {{weight.primitive}} should be renamed from {{XXX}} to {{XXXOperations}} because they actually contain operations on weights (they do not represent weights themselves);
> * in the actual algorithms, all variable names for weight operations should actually be something like {{weightOperations}} instead of the name of the interface (e.g. {{orderedMonoid}}).
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] [Commented] (SANDBOX-395) Correct names for classes and
variables related to operations on weights
Posted by "Claudio Squarcella (Commented) (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/SANDBOX-395?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13213603#comment-13213603 ]
Claudio Squarcella commented on SANDBOX-395:
--------------------------------------------
Cool, I just committed!
> Correct names for classes and variables related to operations on weights
> ------------------------------------------------------------------------
>
> Key: SANDBOX-395
> URL: https://issues.apache.org/jira/browse/SANDBOX-395
> Project: Commons Sandbox
> Issue Type: Improvement
> Components: Graph
> Reporter: Claudio Squarcella
> Assignee: Claudio Squarcella
> Priority: Minor
> Labels: graph, operations, weight
> Attachments: SANDBOX-395_CorrectClassAndVariableNamesForWeightOperations.patch
>
>
> Hi all,
> as discussed in ML already the current classes/variables that refer to operations on weights can be renamed for better expressiveness:
> * all the classes under {{weight.primitive}} should be renamed from {{XXX}} to {{XXXOperations}} because they actually contain operations on weights (they do not represent weights themselves);
> * in the actual algorithms, all variable names for weight operations should actually be something like {{weightOperations}} instead of the name of the interface (e.g. {{orderedMonoid}}).
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] [Updated] (SANDBOX-395) Correct names for classes and
variables related to operations on weights
Posted by "Claudio Squarcella (Updated) (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/SANDBOX-395?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Claudio Squarcella updated SANDBOX-395:
---------------------------------------
Attachment: SANDBOX-395_CorrectClassAndVariableNamesForWeightOperations.patch
Hi,
I attach my proposed change as anticipated on mailing list. Note that:
* all base implementations of weight operations change names with the new pattern {{*BaseOperations}} (e.g. {{DoubleWeight}} becomes {{DoubleWeightBaseOperations}});
* all weight-operation variables passed to algorithms and data structures change name from the implemented interface (e.g. {{orderedMonoid}}) to {{weightOperations}}. To reflect this also the generic type changes from {{OM}} to {{WO}};
* all comments, documentation and null-check strings are changed accordingly;
* in {{SuperVertex}} the {{Comparator}} needed for the operations is called {{weightComparator}}.
> Correct names for classes and variables related to operations on weights
> ------------------------------------------------------------------------
>
> Key: SANDBOX-395
> URL: https://issues.apache.org/jira/browse/SANDBOX-395
> Project: Commons Sandbox
> Issue Type: Improvement
> Components: Graph
> Reporter: Claudio Squarcella
> Assignee: Claudio Squarcella
> Priority: Minor
> Labels: graph, operations, weight
> Attachments: SANDBOX-395_CorrectClassAndVariableNamesForWeightOperations.patch
>
>
> Hi all,
> as discussed in ML already the current classes/variables that refer to operations on weights can be renamed for better expressiveness:
> * all the classes under {{weight.primitive}} should be renamed from {{XXX}} to {{XXXOperations}} because they actually contain operations on weights (they do not represent weights themselves);
> * in the actual algorithms, all variable names for weight operations should actually be something like {{weightOperations}} instead of the name of the interface (e.g. {{orderedMonoid}}).
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira