You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hive.apache.org by "Philip Tromans (JIRA)" <ji...@apache.org> on 2012/07/18 16:56:34 UTC

[jira] [Commented] (HIVE-2843) UDAF to convert an aggregation to a map

    [ https://issues.apache.org/jira/browse/HIVE-2843?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13417144#comment-13417144 ] 

Philip Tromans commented on HIVE-2843:
--------------------------------------

Hi David,

I think that this would be a really useful addition to Hive. I was just about to write the same UDAF when I came across yours. I think implode_to_map is a good name for it, because as you say, implode has quite a few meanings, but I'm interested in what others have to say.

I don't mind preparing / submitting the patch / test cases if you're working on other things.

Cheers,

Phil.
                
> UDAF to convert an aggregation to a map
> ---------------------------------------
>
>                 Key: HIVE-2843
>                 URL: https://issues.apache.org/jira/browse/HIVE-2843
>             Project: Hive
>          Issue Type: New Feature
>          Components: UDF
>    Affects Versions: 0.9.0
>            Reporter: David Worms
>            Priority: Minor
>              Labels: features, udf
>
> I propose the addition of two new Hive UDAF to help with maps in Apache Hive. The source code is available on GitHub at https://github.com/wdavidw/hive-udf in two Java classes: "UDAFToMap" and "UDAFToOrderedMap". The first function convert an aggregation into a map and is internally using a Java `HashMap`. The second function extends the first one. It convert an aggregation into an ordered map and is internally using a Java `TreeMap`. They both extends the `AbstractGenericUDAFResolver` class.
> Also, I have covered the motivations and usages of those UDAF in a blog post at http://adaltas.com/blog/2012/03/06/hive-udaf-map-conversion/
> If you are interested by my proposal, I'll take the time to update this issue while following the guideline posted on the wiki to create an appropriate path.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira