You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-dev@hadoop.apache.org by "Paul Saab (JIRA)" <ji...@apache.org> on 2007/11/22 07:48:43 UTC
[jira] Created: (HADOOP-2264) Support an OutputFormat for HQL row
data
Support an OutputFormat for HQL row data
----------------------------------------
Key: HADOOP-2264
URL: https://issues.apache.org/jira/browse/HADOOP-2264
Project: Hadoop
Issue Type: New Feature
Components: contrib/hbase
Reporter: Paul Saab
Currently when selecting a row, if the data does not convert to a String the hbase shell will print garbage. It would be nice if HQL supported a mechanism to format individual columns. Something along the lines of:
select col1: format(SomeFormatClass), col2: format(AnotherFormatClass) from table ....
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Updated: (HADOOP-2264) Support an OutputFormat for HQL row
data
Posted by "Edward Yoon (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-2264?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Edward Yoon updated HADOOP-2264:
--------------------------------
Priority: Major (was: Trivial)
I think It is a important thing.
> Support an OutputFormat for HQL row data
> ----------------------------------------
>
> Key: HADOOP-2264
> URL: https://issues.apache.org/jira/browse/HADOOP-2264
> Project: Hadoop
> Issue Type: New Feature
> Components: contrib/hbase
> Reporter: Paul Saab
> Assignee: Edward Yoon
>
> Currently when selecting a row, if the data does not convert to a String the hbase shell will print garbage. It would be nice if HQL supported a mechanism to format individual columns. Something along the lines of:
> select col1: format(SomeFormatClass), col2: format(AnotherFormatClass) from table ....
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Commented: (HADOOP-2264) Support an OutputFormat for HQL row
data
Posted by "Edward Yoon (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-2264?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12544781 ]
Edward Yoon commented on HADOOP-2264:
-------------------------------------
Thanks, Paul.
If you'll work on it, please write the plan about UDC.
I'll help you for clarify the grammars.
P.S. This issue object need type casting as a (HbaseShell)
:)
> Support an OutputFormat for HQL row data
> ----------------------------------------
>
> Key: HADOOP-2264
> URL: https://issues.apache.org/jira/browse/HADOOP-2264
> Project: Hadoop
> Issue Type: New Feature
> Components: contrib/hbase
> Reporter: Paul Saab
>
> Currently when selecting a row, if the data does not convert to a String the hbase shell will print garbage. It would be nice if HQL supported a mechanism to format individual columns. Something along the lines of:
> select col1: format(SomeFormatClass), col2: format(AnotherFormatClass) from table ....
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Assigned: (HADOOP-2264) Support an OutputFormat for HQL row
data
Posted by "Edward Yoon (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-2264?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Edward Yoon reassigned HADOOP-2264:
-----------------------------------
Assignee: Edward Yoon
> Support an OutputFormat for HQL row data
> ----------------------------------------
>
> Key: HADOOP-2264
> URL: https://issues.apache.org/jira/browse/HADOOP-2264
> Project: Hadoop
> Issue Type: New Feature
> Components: contrib/hbase
> Reporter: Paul Saab
> Assignee: Edward Yoon
>
> Currently when selecting a row, if the data does not convert to a String the hbase shell will print garbage. It would be nice if HQL supported a mechanism to format individual columns. Something along the lines of:
> select col1: format(SomeFormatClass), col2: format(AnotherFormatClass) from table ....
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Issue Comment Edited: (HADOOP-2264) Support an OutputFormat
for HQL row data
Posted by "Edward Yoon (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-2264?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12544726 ]
udanax edited comment on HADOOP-2264 at 11/22/07 12:58 AM:
----------------------------------------------------------------
I'd recommend changing from the grammar of above to UDC(user-defined casts), Paul.
{code}ex. select MyCast(col1:) from table ...{code}
"select col1: format(SomeFormatClass), col2: format(AnotherFormatClass) from table ...."
is too heterogeneous from select statement.
was (Author: udanax):
I'd recommend changing the grammar of above to UDC(user-defined casts), Paul.
ex. select MyCast(col1:) from table ...
"select col1: format(SomeFormatClass), col2: format(AnotherFormatClass) from table ...."
is too heterogeneous from select statement.
> Support an OutputFormat for HQL row data
> ----------------------------------------
>
> Key: HADOOP-2264
> URL: https://issues.apache.org/jira/browse/HADOOP-2264
> Project: Hadoop
> Issue Type: New Feature
> Components: contrib/hbase
> Reporter: Paul Saab
>
> Currently when selecting a row, if the data does not convert to a String the hbase shell will print garbage. It would be nice if HQL supported a mechanism to format individual columns. Something along the lines of:
> select col1: format(SomeFormatClass), col2: format(AnotherFormatClass) from table ....
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Commented: (HADOOP-2264) Support an OutputFormat for HQL row
data
Posted by "Edward Yoon (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-2264?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12545327 ]
Edward Yoon commented on HADOOP-2264:
-------------------------------------
And, i'd like to use the JavaCompiler for runtime compiling, if it is possible.
> Support an OutputFormat for HQL row data
> ----------------------------------------
>
> Key: HADOOP-2264
> URL: https://issues.apache.org/jira/browse/HADOOP-2264
> Project: Hadoop
> Issue Type: New Feature
> Components: contrib/hbase
> Reporter: Paul Saab
>
> Currently when selecting a row, if the data does not convert to a String the hbase shell will print garbage. It would be nice if HQL supported a mechanism to format individual columns. Something along the lines of:
> select col1: format(SomeFormatClass), col2: format(AnotherFormatClass) from table ....
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Updated: (HADOOP-2264) Support an OutputFormat for HQL row
data
Posted by "Edward Yoon (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-2264?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Edward Yoon updated HADOOP-2264:
--------------------------------
Priority: Minor (was: Major)
> Support an OutputFormat for HQL row data
> ----------------------------------------
>
> Key: HADOOP-2264
> URL: https://issues.apache.org/jira/browse/HADOOP-2264
> Project: Hadoop
> Issue Type: New Feature
> Components: contrib/hbase
> Reporter: Paul Saab
> Assignee: Edward Yoon
> Priority: Minor
>
> Currently when selecting a row, if the data does not convert to a String the hbase shell will print garbage. It would be nice if HQL supported a mechanism to format individual columns. Something along the lines of:
> select col1: format(SomeFormatClass), col2: format(AnotherFormatClass) from table ....
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Commented: (HADOOP-2264) Support an OutputFormat for HQL row
data
Posted by "Paul Saab (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-2264?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12544731 ]
Paul Saab commented on HADOOP-2264:
-----------------------------------
This sounds good to me. +1
> Support an OutputFormat for HQL row data
> ----------------------------------------
>
> Key: HADOOP-2264
> URL: https://issues.apache.org/jira/browse/HADOOP-2264
> Project: Hadoop
> Issue Type: New Feature
> Components: contrib/hbase
> Reporter: Paul Saab
>
> Currently when selecting a row, if the data does not convert to a String the hbase shell will print garbage. It would be nice if HQL supported a mechanism to format individual columns. Something along the lines of:
> select col1: format(SomeFormatClass), col2: format(AnotherFormatClass) from table ....
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Commented: (HADOOP-2264) Support an OutputFormat for HQL row
data
Posted by "Edward Yoon (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-2264?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12545369 ]
Edward Yoon commented on HADOOP-2264:
-------------------------------------
>> I suppose we could write one that works with Writables - i.e. pass cell bytes to readField and use the toString as formatter - and that'd be good enough for most needs. Would 'formatter' be a better name than 'MyCast/UDC'? Default it could take column name only and format using Writables. Optionally you could pass in the name of a class to do custom formatting?
I think there is no difference between 'formatter' and 'UDC' in functional/executional ability, michael.
> Support an OutputFormat for HQL row data
> ----------------------------------------
>
> Key: HADOOP-2264
> URL: https://issues.apache.org/jira/browse/HADOOP-2264
> Project: Hadoop
> Issue Type: New Feature
> Components: contrib/hbase
> Reporter: Paul Saab
>
> Currently when selecting a row, if the data does not convert to a String the hbase shell will print garbage. It would be nice if HQL supported a mechanism to format individual columns. Something along the lines of:
> select col1: format(SomeFormatClass), col2: format(AnotherFormatClass) from table ....
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Issue Comment Edited: (HADOOP-2264) Support an OutputFormat
for HQL row data
Posted by "Edward Yoon (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-2264?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12544781 ]
udanax edited comment on HADOOP-2264 at 11/22/07 3:17 AM:
---------------------------------------------------------------
Thanks, Paul.
If you'll work on it, please write the plans about UDC.
I'll help you for clarify the grammars.
P.S. This issue object need type casting as a (HbaseShell)
:)
was (Author: udanax):
Thanks, Paul.
If you'll work on it, please write the plan about UDC.
I'll help you for clarify the grammars.
P.S. This issue object need type casting as a (HbaseShell)
:)
> Support an OutputFormat for HQL row data
> ----------------------------------------
>
> Key: HADOOP-2264
> URL: https://issues.apache.org/jira/browse/HADOOP-2264
> Project: Hadoop
> Issue Type: New Feature
> Components: contrib/hbase
> Reporter: Paul Saab
>
> Currently when selecting a row, if the data does not convert to a String the hbase shell will print garbage. It would be nice if HQL supported a mechanism to format individual columns. Something along the lines of:
> select col1: format(SomeFormatClass), col2: format(AnotherFormatClass) from table ....
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Commented: (HADOOP-2264) Support an OutputFormat for HQL row
data
Posted by "Edward Yoon (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-2264?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12545325 ]
Edward Yoon commented on HADOOP-2264:
-------------------------------------
A user-defined cast is a cast that you define to perform conversion from default data bytes to another data type, either built-in or user-defined.
It is just a definition of functionalize, michael.
> Support an OutputFormat for HQL row data
> ----------------------------------------
>
> Key: HADOOP-2264
> URL: https://issues.apache.org/jira/browse/HADOOP-2264
> Project: Hadoop
> Issue Type: New Feature
> Components: contrib/hbase
> Reporter: Paul Saab
>
> Currently when selecting a row, if the data does not convert to a String the hbase shell will print garbage. It would be nice if HQL supported a mechanism to format individual columns. Something along the lines of:
> select col1: format(SomeFormatClass), col2: format(AnotherFormatClass) from table ....
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Commented: (HADOOP-2264) Support an OutputFormat for HQL row
data
Posted by "Edward Yoon (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-2264?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12544726 ]
Edward Yoon commented on HADOOP-2264:
-------------------------------------
I'd recommend changing the grammar of above to UDC(user-defined casts), Paul.
ex. select MyCast(col1:) from table ...
"select col1: format(SomeFormatClass), col2: format(AnotherFormatClass) from table ...."
is too heterogeneous from select statement.
> Support an OutputFormat for HQL row data
> ----------------------------------------
>
> Key: HADOOP-2264
> URL: https://issues.apache.org/jira/browse/HADOOP-2264
> Project: Hadoop
> Issue Type: New Feature
> Components: contrib/hbase
> Reporter: Paul Saab
>
> Currently when selecting a row, if the data does not convert to a String the hbase shell will print garbage. It would be nice if HQL supported a mechanism to format individual columns. Something along the lines of:
> select col1: format(SomeFormatClass), col2: format(AnotherFormatClass) from table ....
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Updated: (HADOOP-2264) Support an OutputFormat for HQL row
data
Posted by "Bryan Duxbury (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-2264?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Bryan Duxbury updated HADOOP-2264:
----------------------------------
Priority: Trivial (was: Major)
Not major issue.
> Support an OutputFormat for HQL row data
> ----------------------------------------
>
> Key: HADOOP-2264
> URL: https://issues.apache.org/jira/browse/HADOOP-2264
> Project: Hadoop
> Issue Type: New Feature
> Components: contrib/hbase
> Reporter: Paul Saab
> Assignee: Edward Yoon
> Priority: Trivial
>
> Currently when selecting a row, if the data does not convert to a String the hbase shell will print garbage. It would be nice if HQL supported a mechanism to format individual columns. Something along the lines of:
> select col1: format(SomeFormatClass), col2: format(AnotherFormatClass) from table ....
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Commented: (HADOOP-2264) Support an OutputFormat for HQL row
data
Posted by "stack (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-2264?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12545117 ]
stack commented on HADOOP-2264:
-------------------------------
What is 'MyCast'? Or UDC? Is it code that a user would have to add to the CLASSPATH (like PIG) for it to work? If its only input is the column name, then it looks like you'd have to provide a UDC/MyCast per available formatter?
I suppose we could write one that works with Writables -- i.e. pass cell bytes to readField and use the toString as formatter -- and that'd be good enough for most needs.
Would 'formatter' be a better name than 'MyCast/UDC'? Default it could take column name only and format using Writables. Optionally you could pass in the name of a class to do custom formatting?
> Support an OutputFormat for HQL row data
> ----------------------------------------
>
> Key: HADOOP-2264
> URL: https://issues.apache.org/jira/browse/HADOOP-2264
> Project: Hadoop
> Issue Type: New Feature
> Components: contrib/hbase
> Reporter: Paul Saab
>
> Currently when selecting a row, if the data does not convert to a String the hbase shell will print garbage. It would be nice if HQL supported a mechanism to format individual columns. Something along the lines of:
> select col1: format(SomeFormatClass), col2: format(AnotherFormatClass) from table ....
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.