You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@commons.apache.org by Eric Pugh <ep...@upstate.com> on 2005/08/10 03:32:18 UTC

[email] Update on bug list

Hi all,

I checked out 34056 (http://issues.apache.org/bugzilla/show_bug.cgi? 
id=34056) and it doesn't seem bad.   The one thing Henning highlighted:
-                getPrimaryBodyPart().setText(msg, charset);
+//                BROKEN!
+//                getPrimaryBodyPart().setText(msg, charset);
+                getPrimaryBodyPart().setText(msg);

I don't see why this is "broken"...  Seems to me like we add  
getPrimaryBodyPart().setText(msg,charset) as well...

I also looked at 35881 (http://issues.apache.org/bugzilla/ 
show_bug.cgi?id=35881), and despite not being able to apply, the  
change doesn't seem bad either.  I would like to see the 1.0 release  
be one we can rely on for a while, and the changes to faciliate  
subclassing/extension in 34056 and 35881, and then cutting RC6 seem  
like an okay path forward.

Any opinions?   I think at least 35881 can be applied, and if we get  
back the info on 34056 on the // BROKEN bit, then it could go in as  
well.   Commons-email has taken this long, whats another week or two...

Eric



---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Re: [email] Update on bug list

Posted by "Henning P. Schmiedehausen" <hp...@intermeta.de>.
Eric Pugh <ep...@upstate.com> writes:

>Hi all,

>I checked out 34056 (http://issues.apache.org/bugzilla/show_bug.cgi? 
>id=34056) and it doesn't seem bad.   The one thing Henning highlighted:
>-                getPrimaryBodyPart().setText(msg, charset);
>+//                BROKEN!
>+//                getPrimaryBodyPart().setText(msg, charset);
>+                getPrimaryBodyPart().setText(msg);

>I don't see why this is "broken"...  Seems to me like we add  
>getPrimaryBodyPart().setText(msg,charset) as well...

To add some bikeshed painting:

If you make (or just make sure) setText(msg, null) to behave like
setText(msg) then the whole conditional can go.

	Regards
		Henning

-- 
Dipl.-Inf. (Univ.) Henning P. Schmiedehausen          INTERMETA GmbH
hps@intermeta.de        +49 9131 50 654 0   http://www.intermeta.de/

RedHat Certified Engineer -- Jakarta Turbine Development  -- hero for hire
   Linux, Java, perl, Solaris -- Consulting, Training, Development

		      4 - 8 - 15 - 16 - 23 - 42

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Re: [email] Update on bug list

Posted by Corey Scott <co...@gmail.com>.
All of this sounds good, but I havent had a chance to test it myself as yet.

+1

-Corey

On 8/10/05, Eric Pugh <ep...@upstate.com> wrote:
> Hi all,
> 
> I checked out 34056 (http://issues.apache.org/bugzilla/show_bug.cgi?
> id=34056) and it doesn't seem bad.   The one thing Henning highlighted:
> -                getPrimaryBodyPart().setText(msg, charset);
> +//                BROKEN!
> +//                getPrimaryBodyPart().setText(msg, charset);
> +                getPrimaryBodyPart().setText(msg);
> 
> I don't see why this is "broken"...  Seems to me like we add
> getPrimaryBodyPart().setText(msg,charset) as well...
> 
> I also looked at 35881 (http://issues.apache.org/bugzilla/
> show_bug.cgi?id=35881), and despite not being able to apply, the
> change doesn't seem bad either.  I would like to see the 1.0 release
> be one we can rely on for a while, and the changes to faciliate
> subclassing/extension in 34056 and 35881, and then cutting RC6 seem
> like an okay path forward.
> 
> Any opinions?   I think at least 35881 can be applied, and if we get
> back the info on 34056 on the // BROKEN bit, then it could go in as
> well.   Commons-email has taken this long, whats another week or two...
> 
> Eric
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
> 
>

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Re: [email] Update on bug list

Posted by Dion Gillard <di...@gmail.com>.
+1.

On 8/10/05, Eric Pugh <ep...@upstate.com> wrote:
> Hi all,
> 
> I checked out 34056 (http://issues.apache.org/bugzilla/show_bug.cgi?
> id=34056) and it doesn't seem bad.   The one thing Henning highlighted:
> -                getPrimaryBodyPart().setText(msg, charset);
> +//                BROKEN!
> +//                getPrimaryBodyPart().setText(msg, charset);
> +                getPrimaryBodyPart().setText(msg);
> 
> I don't see why this is "broken"...  Seems to me like we add
> getPrimaryBodyPart().setText(msg,charset) as well...
> 
> I also looked at 35881 (http://issues.apache.org/bugzilla/
> show_bug.cgi?id=35881), and despite not being able to apply, the
> change doesn't seem bad either.  I would like to see the 1.0 release
> be one we can rely on for a while, and the changes to faciliate
> subclassing/extension in 34056 and 35881, and then cutting RC6 seem
> like an okay path forward.
> 
> Any opinions?   I think at least 35881 can be applied, and if we get
> back the info on 34056 on the // BROKEN bit, then it could go in as
> well.   Commons-email has taken this long, whats another week or two...
> 
> Eric
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
> 
> 


-- 
http://www.multitask.com.au/people/dion/
"You are going to let the fear of poverty govern your life and your
reward will be that you will eat, but you will not live." - George
Bernard Shaw

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org