You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@cordova.apache.org by ma...@apache.org on 2026/03/25 13:23:21 UTC
(cordova-plugin-camera) branch pr-readme-use-native-browser-features updated (5ed5a94 -> cd73130)
This is an automated email from the ASF dual-hosted git repository.
manuelbeck pushed a change to branch pr-readme-use-native-browser-features
in repository https://gitbox.apache.org/repos/asf/cordova-plugin-camera.git
from 5ed5a94 Some small text fixes
add 5999548 chore(ci): update obsolete XCode versions, add iOS 18 and 26 (#938)
add dc682b2 feat(ios): use `PHPickerViewController` for iOS 14+ (#937)
add 90ad137 fix(ios)! remove iPadOS popover code (#941)
add d731cb9 fix(ios): don't copy temporary video file on main thread and cleanup (#942)
add fe1896c doc(ios): Document `PHPickerConfigurationAssetRepresentationModeCurrent` (#945)
add 3c12685 fix(ios): get correctly metadata with `PHPicker` (#944)
add b75cff8 ios: rename method `finalizePHPickerImage:` and document it (#947)
add 77e85f2 ios! rename `CDVCameraPicker` to `CDVUIImagePickerController` (#948)
add 1848db0 ios: rename property `pickerController` to `cdvUIImagePickerController` (#949)
add 59f4219 refactor(ios): `processPHPickerImage:` and `retrieveImage:` (#952)
add 44e095f chore(dev-deps): bump @cordova/eslint-config to 6.0.1 w/ fixes (#956)
add 64f4022 feat(android)!: bump ANDROIDX_CORE_VERSION default 1.18.0 (#957)
add 0d5a8e2 chore(ci): draft release (#959)
add de966b4 doc: update & cleanup README, DEVELOPMENT & CONTRIBUTING (#955)
add 571f116 chore(license): update header formatting (#958)
add c34106e chore(ci): update workflows (#960)
add cd73130 merge master into pr
No new revisions were added by this update.
Summary of changes:
.eslintrc.yml => .asf-release/.gitkeep | 11 +-
.asf.yaml | 4 +-
.gitattributes | 17 +
.github/workflows/android.yml | 47 +-
.github/workflows/chrome.yml | 13 +-
.github/workflows/draft-release.yml | 149 +
.github/workflows/ios.yml | 28 +-
.github/workflows/lint.yml | 13 +-
.github/workflows/release-audit.yml | 55 +
.github/workflows/release-notify.yml | 13 -
.gitignore | 21 +-
.npmignore | 20 +
.npmrc | 21 +
.eslintrc.yml => .rat-excludes | 10 +-
.eslintrc.yml => .ratignore | 10 +-
CONTRIBUTING.md | 33 +-
DEVELOPMENT.md | 100 +
README.md | 467 +--
RELEASENOTES.md | 4 +-
eslint.config.js | 55 +
.eslintrc.yml => licence_checker.yml | 8 +-
package-lock.json | 4424 ++++++++------------
package.json | 5 +-
plugin.xml | 47 +-
src/android/CameraLauncher.java | 47 +-
src/android/ExifHelper.java | 32 +-
src/android/FileHelper.java | 32 +-
src/android/FileProvider.java | 28 +-
src/android/GalleryPathVO.java | 28 +-
src/android/xml/camera_provider_paths.xml | 31 +-
src/browser/CameraProxy.js | 36 +-
src/ios/CDVCamera.h | 100 +-
src/ios/CDVCamera.m | 953 +++--
src/ios/CDVExif.h | 30 +-
src/ios/CDVJpegHeaderWriter.h | 30 +-
src/ios/CDVJpegHeaderWriter.m | 34 +-
src/ios/UIImage+CropScaleOrientation.h | 36 +-
src/ios/UIImage+CropScaleOrientation.m | 34 +-
tests/ios/.gitignore | 19 +-
.../contents.xcworkspacedata | 18 +
.../xcshareddata/CDVCameraTest.xccheckout | 18 +
.../xcshareddata/xcschemes/CordovaLib.xcscheme | 18 +
.../CDVCameraTest/CDVCameraLibTests/CameraTest.m | 209 +-
.../ios/CDVCameraTest/CDVCameraLibTests/Info.plist | 34 +-
.../CDVCameraTest.xcodeproj/project.pbxproj | 18 +
.../project.xcworkspace/contents.xcworkspacedata | 18 +
.../xcshareddata/CDVCameraTest.xccheckout | 18 +
.../xcshareddata/xcschemes/CDVCameraLib.xcscheme | 18 +
.../xcschemes/CDVCameraLibTests.xcscheme | 18 +
tests/ios/README.md | 34 +-
tests/plugin.xml | 29 +-
tests/tests.js | 49 +-
types/index.d.ts | 55 +-
www/Camera.js | 42 +-
www/CameraConstants.js | 55 +-
www/CameraPopoverHandle.js | 32 -
www/CameraPopoverOptions.js | 56 -
www/ios/CameraPopoverHandle.js | 66 -
58 files changed, 3733 insertions(+), 4117 deletions(-)
copy .eslintrc.yml => .asf-release/.gitkeep (80%)
create mode 100644 .github/workflows/draft-release.yml
create mode 100644 .github/workflows/release-audit.yml
delete mode 100644 .github/workflows/release-notify.yml
copy .eslintrc.yml => .rat-excludes (84%)
copy .eslintrc.yml => .ratignore (84%)
create mode 100644 DEVELOPMENT.md
create mode 100644 eslint.config.js
rename .eslintrc.yml => licence_checker.yml (84%)
delete mode 100644 www/CameraPopoverHandle.js
delete mode 100644 www/CameraPopoverOptions.js
delete mode 100644 www/ios/CameraPopoverHandle.js
---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@cordova.apache.org
For additional commands, e-mail: commits-help@cordova.apache.org