You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-dev@hadoop.apache.org by "Doug Cutting (JIRA)" <ji...@apache.org> on 2006/08/28 22:00:23 UTC
[jira] Commented: (HADOOP-481) Hadoop mapred metrics should include
per job input/output statistics rather than per-task statistics
[ http://issues.apache.org/jira/browse/HADOOP-481?page=comments#action_12431048 ]
Doug Cutting commented on HADOOP-481:
-------------------------------------
Instead of passing a long[] you should pass a struct that implements Writable. Probably TaskMetrics would be a good name for this.
> Hadoop mapred metrics should include per job input/output statistics rather than per-task statistics
> ----------------------------------------------------------------------------------------------------
>
> Key: HADOOP-481
> URL: http://issues.apache.org/jira/browse/HADOOP-481
> Project: Hadoop
> Issue Type: Improvement
> Components: mapred, metrics
> Affects Versions: 0.6.0
> Reporter: Milind Bhandarkar
> Assigned To: Milind Bhandarkar
> Priority: Minor
> Fix For: 0.6.0
>
> Attachments: reports.patch
>
>
> Currently hadoop reports metrics such as input bytes, input records, etc on per-task basis. Accurate aggregation of these metrics is required at the job-level and reporting should be done on a per-job basis.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira