You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@tez.apache.org by "Junping Du (JIRA)" <ji...@apache.org> on 2017/04/24 17:48:04 UTC

[jira] [Comment Edited] (TEZ-2049) Remove YARN references from Tez AsyncDispatcher

    [ https://issues.apache.org/jira/browse/TEZ-2049?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15981568#comment-15981568 ] 

Junping Du edited comment on TEZ-2049 at 4/24/17 5:47 PM:
----------------------------------------------------------

Thanks [~aplusplus] for reporting the issue and delivering a fix. A quick comment:
{noformat}
+  @VisibleForTesting
+  public void disableExitOnDispatchException() {
+    exitOnDispatchException = true;
+  }
{noformat}
The method name seems a bit misleading. May be we should rename to something like: enableExitOnDispatchException, setExitOnDispatchException, etc.?
Other looks good to me.


was (Author: djp):
Thanks [~aplusplus] for reporting the issue and delivering a fix. A quick comment:
{noformat}
+  @VisibleForTesting
+  public void disableExitOnDispatchException() {
+    exitOnDispatchException = true;
+  }
{noformat}
The method name seems a bit misleading. May be we should rename to something like: enableExitOnDispatch, setExitOnDispatchException, etc.?
Other looks good to me.

> Remove YARN references from Tez AsyncDispatcher
> -----------------------------------------------
>
>                 Key: TEZ-2049
>                 URL: https://issues.apache.org/jira/browse/TEZ-2049
>             Project: Apache Tez
>          Issue Type: Sub-task
>            Reporter: Bikas Saha
>            Assignee: Zhiyuan Yang
>         Attachments: TEZ-2049.1.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.3.15#6346)