You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@bookkeeper.apache.org by "Ivan Kelly (Created) (JIRA)" <ji...@apache.org> on 2012/03/20 16:11:43 UTC

[jira] [Created] (BOOKKEEPER-188) Garbage collection code is in the wrong place

Garbage collection code is in the wrong place
---------------------------------------------

                 Key: BOOKKEEPER-188
                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-188
             Project: Bookkeeper
          Issue Type: Bug
            Reporter: Ivan Kelly
            Assignee: Ivan Kelly
             Fix For: 4.1.0


There's a lot of garbage collection code in the wrong place in EntryLogger. extractMetaFromEntryLogs, and EntryLogMetadata are only every used in the GC Thread. So they should move there.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (BOOKKEEPER-188) Garbage collection code is in the wrong place

Posted by "Hudson (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/BOOKKEEPER-188?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13234130#comment-13234130 ] 

Hudson commented on BOOKKEEPER-188:
-----------------------------------

Integrated in bookkeeper-trunk #420 (See [https://builds.apache.org/job/bookkeeper-trunk/420/])
    BOOKKEEPER-188: Garbage collection code is in the wrong place (ivank via sijie) (Revision 1303286)

     Result = ABORTED
sijie : 
Files : 
* /zookeeper/bookkeeper/trunk/CHANGES.txt
* /zookeeper/bookkeeper/trunk/bookkeeper-server/src/main/java/org/apache/bookkeeper/bookie/EntryLogger.java
* /zookeeper/bookkeeper/trunk/bookkeeper-server/src/main/java/org/apache/bookkeeper/bookie/GarbageCollectorThread.java
* /zookeeper/bookkeeper/trunk/bookkeeper-server/src/test/java/org/apache/bookkeeper/bookie/EntryLogTest.java

                
> Garbage collection code is in the wrong place
> ---------------------------------------------
>
>                 Key: BOOKKEEPER-188
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-188
>             Project: Bookkeeper
>          Issue Type: Bug
>            Reporter: Ivan Kelly
>            Assignee: Ivan Kelly
>             Fix For: 4.1.0
>
>         Attachments: BOOKKEEPER-188.diff
>
>
> There's a lot of garbage collection code in the wrong place in EntryLogger. extractMetaFromEntryLogs, and EntryLogMetadata are only every used in the GC Thread. So they should move there.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (BOOKKEEPER-188) Garbage collection code is in the wrong place

Posted by "Ivan Kelly (Updated) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/BOOKKEEPER-188?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Ivan Kelly updated BOOKKEEPER-188:
----------------------------------

    Attachment: BOOKKEEPER-188.diff

This is a very straight forward refactor. The one functional change is that extractMetaFromEntryLogs now call extractMetaFromEntryLog rather than having duplicate logic in each.
                
> Garbage collection code is in the wrong place
> ---------------------------------------------
>
>                 Key: BOOKKEEPER-188
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-188
>             Project: Bookkeeper
>          Issue Type: Bug
>            Reporter: Ivan Kelly
>            Assignee: Ivan Kelly
>             Fix For: 4.1.0
>
>         Attachments: BOOKKEEPER-188.diff
>
>
> There's a lot of garbage collection code in the wrong place in EntryLogger. extractMetaFromEntryLogs, and EntryLogMetadata are only every used in the GC Thread. So they should move there.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (BOOKKEEPER-188) Garbage collection code is in the wrong place

Posted by "Sijie Guo (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/BOOKKEEPER-188?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13234102#comment-13234102 ] 

Sijie Guo commented on BOOKKEEPER-188:
--------------------------------------

+1 for the patch, will commit it.
                
> Garbage collection code is in the wrong place
> ---------------------------------------------
>
>                 Key: BOOKKEEPER-188
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-188
>             Project: Bookkeeper
>          Issue Type: Bug
>            Reporter: Ivan Kelly
>            Assignee: Ivan Kelly
>             Fix For: 4.1.0
>
>         Attachments: BOOKKEEPER-188.diff
>
>
> There's a lot of garbage collection code in the wrong place in EntryLogger. extractMetaFromEntryLogs, and EntryLogMetadata are only every used in the GC Thread. So they should move there.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (BOOKKEEPER-188) Garbage collection code is in the wrong place

Posted by "jiraposter@reviews.apache.org (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/BOOKKEEPER-188?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13233475#comment-13233475 ] 

jiraposter@reviews.apache.org commented on BOOKKEEPER-188:
----------------------------------------------------------


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/4414/
-----------------------------------------------------------

Review request for bookkeeper.


Summary
-------

This is a very straight forward refactor. The one functional change is that extractMetaFromEntryLogs now call extractMetaFromEntryLog rather than having duplicate logic in each.


This addresses bug BOOKKEEPER-188.
    https://issues.apache.org/jira/browse/BOOKKEEPER-188


Diffs
-----

  bookkeeper-server/src/main/java/org/apache/bookkeeper/bookie/EntryLogger.java 8da372e 
  bookkeeper-server/src/main/java/org/apache/bookkeeper/bookie/GarbageCollectorThread.java 23f02bc 
  bookkeeper-server/src/test/java/org/apache/bookkeeper/bookie/EntryLogTest.java 96df89a 

Diff: https://reviews.apache.org/r/4414/diff


Testing
-------


Thanks,

Ivan


                
> Garbage collection code is in the wrong place
> ---------------------------------------------
>
>                 Key: BOOKKEEPER-188
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-188
>             Project: Bookkeeper
>          Issue Type: Bug
>            Reporter: Ivan Kelly
>            Assignee: Ivan Kelly
>             Fix For: 4.1.0
>
>         Attachments: BOOKKEEPER-188.diff
>
>
> There's a lot of garbage collection code in the wrong place in EntryLogger. extractMetaFromEntryLogs, and EntryLogMetadata are only every used in the GC Thread. So they should move there.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira