You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Shilun Fan (Jira)" <ji...@apache.org> on 2024/01/04 08:36:00 UTC

[jira] [Updated] (YARN-9856) Remove log-aggregation related duplicate function

     [ https://issues.apache.org/jira/browse/YARN-9856?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Shilun Fan updated YARN-9856:
-----------------------------
    Target Version/s: 3.5.0  (was: 3.4.0)

> Remove log-aggregation related duplicate function
> -------------------------------------------------
>
>                 Key: YARN-9856
>                 URL: https://issues.apache.org/jira/browse/YARN-9856
>             Project: Hadoop YARN
>          Issue Type: Task
>          Components: log-aggregation, yarn
>    Affects Versions: 3.3.0
>            Reporter: Adam Antal
>            Assignee: Szilard Nemeth
>            Priority: Trivial
>         Attachments: YARN-9856.001.patch, YARN-9856.002.patch
>
>
> [~snemeth] has noticed a duplication in two of the log-aggregation related functions.
> {quote}I noticed duplicated code in org.apache.hadoop.yarn.logaggregation.LogToolUtils#outputContainerLog, duplicated in org.apache.hadoop.yarn.logaggregation.AggregatedLogFormat.LogReader#readContainerLogs. [...]
> {quote}
> We should remove the duplication.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org