You are viewing a plain text version of this content. The canonical link for it is here.
Posted to announce@apache.org by Abhishek Choudhary <sh...@apache.org> on 2026/06/19 06:57:08 UTC
CVE-2026-49230: Apache APISIX: Authentication bypass in jwe-decrypt
Severity:
Affected versions:
- Apache APISIX 3.8.0 through 3.16.0
Description:
Improper Validation of Integrity Check Value vulnerability in Apache APISIX.
The jwe-decrypt plugin under default configuration is vulnerable to authentication bypass.
This issue affects Apache APISIX: from 3.8.0 through 3.16.0.
Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Credit:
lokerxxx (reporter)
References:
https://apisix.apache.org
https://www.cve.org/CVERecord?id=CVE-2026-49230