You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@camel.apache.org by "Andrea Cosentino (Jira)" <ji...@apache.org> on 2026/06/12 10:15:00 UTC
[jira] [Commented] (CAMEL-23510) camel-jgroups: align Exchange header constant names with Camel naming convention
[ https://issues.apache.org/jira/browse/CAMEL-23510?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=18088491#comment-18088491 ]
Andrea Cosentino commented on CAMEL-23510:
------------------------------------------
The camel-jgroups Exchange header constant rename has been completed and verified:
* Code merged on main, camel-4.18.x, and camel-4.14.x
* Upgrade-guide entries present in camel-4x-upgrade-guide-4_21.adoc, 4_18.adoc and 4_14.adoc on main (flagged as potential breaking change)
fixVersions: 4.14.8, 4.18.3, 4.21.0. Resolving as Fixed.
_Claude Code on behalf of Andrea Cosentino_
> camel-jgroups: align Exchange header constant names with Camel naming convention
> --------------------------------------------------------------------------------
>
> Key: CAMEL-23510
> URL: https://issues.apache.org/jira/browse/CAMEL-23510
> Project: Camel
> Issue Type: Improvement
> Components: camel-jgroups
> Reporter: Andrea Cosentino
> Assignee: Andrea Cosentino
> Priority: Major
> Fix For: 4.14.8, 4.18.3, 4.21.0
>
>
> The Exchange header constants in JGroupsConstants use raw uppercase values (JGROUPS_DEST, JGROUPS_SRC, JGROUPS_CHANNEL_ADDRESS, JGROUPS_ORIGINAL_MESSAGE) that do not follow the Camel naming convention.
> Rename to follow the CamelJGroups* convention and add an entry to the upgrade guide.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)