You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@metron.apache.org by "Justin Leet (JIRA)" <ji...@apache.org> on 2018/05/31 13:10:00 UTC

[jira] [Created] (METRON-1589) '/api/v1/search/search' fails when 'Solr Zookeeper Urls' has comma separated multiple zookeeper urls

Justin Leet created METRON-1589:
-----------------------------------

             Summary: '/api/v1/search/search' fails when 'Solr Zookeeper Urls' has comma separated multiple zookeeper urls
                 Key: METRON-1589
                 URL: https://issues.apache.org/jira/browse/METRON-1589
             Project: Metron
          Issue Type: Sub-task
            Reporter: Justin Leet
            Assignee: Justin Leet


http://metronnode:8082/api/v1/search/search with below payload fails with internal server error when 'Solr Zookeeper Urls' has comma separated multiple zookeeper urls

{code:java}
{
 "indices": [],
 "facetFields": [],
 "query": "*",
 "from": 0,
 "size": 25
}
{code}


{code:java}
{"responseCode":500,"message":"Cannot connect to cluster at ctr-e138-1518143905142-328005-01-000006.hwx.site:2181/solr,ctr-e138-1518143905142-328005-01-000005.hwx.site:2181/solr: cluster not found/not ready","fullMessage":"SolrException: Cannot connect to cluster at ctr-e138-1518143905142-328005-01-000006.hwx.site:2181/solr,ctr-e138-1518143905142-328005-01-000005.hwx.site:2181/solr: cluster not found/not ready"}
{code}

 

This appears to result from here [SolrDao.java#L137-L144|https://github.com/apache/metron/blob/feature/METRON-1416-upgrade-solr/metron-platform/metron-solr/src/main/java/org/apache/metron/solr/dao/SolrDao.java#L137-L144]

In `getSolrClient`, `withZkHost` should be called multiple times after splitting the comma delimited string, per [CloudSolrClient.Builder#withZkHost|https://lucene.apache.org/solr/6_5_0/solr-solrj/org/apache/solr/client/solrj/impl/CloudSolrClient.Builder.html#withZkHost-java.lang.String-].

Overall, this could probably be done a couple ways, either to just split the String directly, or rearrange the methods to pass around Lists and have `getZkHost` be changed to `getZkHosts` and take care of it in a more contained manner.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)