You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ignite.apache.org by "Maksim Timonin (Jira)" <ji...@apache.org> on 2021/10/12 13:41:00 UTC

[jira] [Created] (IGNITE-15731) Refactor how CacheQueryReducer handles remote nodes

Maksim Timonin created IGNITE-15731:
---------------------------------------

             Summary: Refactor how CacheQueryReducer handles remote nodes
                 Key: IGNITE-15731
                 URL: https://issues.apache.org/jira/browse/IGNITE-15731
             Project: Ignite
          Issue Type: Improvement
            Reporter: Maksim Timonin
            Assignee: Maksim Timonin


Refactoring should cover next things:
 # `checkNodeLeft` should be removed. Discovery guarantees order of messages, so we already have info about left nodes. Let's leverage on this.
 # Send requests locally invokes `GridCacheQueryRequest#beforeLocalExecution`. Why do we need this.
 # Duplicated code for cancel requests (it pretty the same for requesting ordinary pages)



--
This message was sent by Atlassian Jira
(v8.3.4#803005)